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Chapter

1
Introduction

IBM SPSS Amos implements the general approach to data analysis known as 
structural equation modeling (SEM), also known as analysis of covariance 
structures, or causal modeling. This approach includes, as special cases, many well-
known conventional techniques, including the general linear model and common 
factor analysis.

Amos (Analysis of Moment Structures) is an easy-to-use program for visual SEM. 
With Amos, you can quickly specify, view, and modify your model graphically 
using simple drawing tools. Then you can assess your model’s fit, make any 
modifications, and print out a publication-quality graphic of your final model. 
Simply specify the model graphically (left). Amos quickly performs the 
computations and displays the results (right).
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Structural equation modeling (SEM) is sometimes thought of as esoteric and difficult 
to learn and use. This is incorrect. Indeed, the growing importance of SEM in data 
analysis is largely due to its ease of use. SEM opens the door for nonstatisticians to 
solve estimation and hypothesis testing problems that once would have required the 
services of a specialist. 

Amos was originally designed as a tool for teaching this powerful and 
fundamentally simple method. For this reason, every effort was made to see that it is 
easy to use. Amos integrates an easy-to-use graphical interface with an advanced 
computing engine for SEM. The publication-quality path diagrams of Amos provide a 
clear representation of models for students and fellow researchers. The numeric 
methods implemented in Amos are among the most effective and reliable available.

Featured Methods

Amos provides the following methods for estimating structural equation models: 

Maximum likelihood

Unweighted least squares

Generalized least squares

Browne’s asymptotically distribution-free criterion

Scale-free least squares

Bayesian estimation

Amos goes well beyond the usual capabilities found in other structural equation 
modeling programs. When confronted with missing data, Amos performs 
state-of-the-art estimation by full information maximum likelihood instead of relying 
on ad-hoc methods like listwise or pairwise deletion, or mean imputation. The program 
can analyze data from several populations at once. It can also estimate means for 
exogenous variables and intercepts in regression equations. 

The program makes bootstrapped standard errors and confidence intervals available 
for all parameter estimates, effect estimates, sample means, variances, covariances, 
and correlations. It also implements percentile intervals and bias-corrected percentile 
intervals (Stine, 1989), as well as Bollen and Stine’s (1992) bootstrap approach to 
model testing.

Multiple models can be fitted in a single analysis. Amos examines every pair of 
models in which one model can be obtained by placing restrictions on the parameters 
of the other. The program reports several statistics appropriate for comparing such 
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models. It provides a test of univariate normality for each observed variable as well as 
a test of multivariate normality and attempts to detect outliers.

Amos accepts a path diagram as a model specification and displays parameter 
estimates graphically on a path diagram. Path diagrams used for model specification 
and those that display parameter estimates are of presentation quality. They can be 
printed directly or imported into other applications such as word processors, desktop 
publishing programs, and general-purpose graphics programs.

About the Tutorial

The tutorial is designed to get you up and running with Amos Graphics. It covers some 
of the basic functions and features and guides you through your first Amos analysis. 

Once you have worked through the tutorial, you can learn about more advanced 
functions using the online Help, or you can continue working through the examples to 
get a more extended introduction to structural modeling with Amos.

About the Examples

Many people like to learn by doing. Knowing this, we have developed many examples 
that quickly demonstrate practical ways to use Amos. The initial examples introduce 
the basic capabilities of Amos as applied to simple problems. You learn which buttons 
to click, how to access the several supported data formats, and how to maneuver 
through the output. Later examples tackle more advanced modeling problems and are 
less concerned with program interface issues. 

Examples 1 through 4 show how you can use Amos to do some conventional 
analyses—analyses that could be done using a standard statistics package. These 
examples show a new approach to some familiar problems while also demonstrating 
all of the basic features of Amos. There are sometimes good reasons for using Amos 
to do something simple, like estimating a mean or correlation or testing the hypothesis 
that two means are equal. For one thing, you might want to take advantage of the ability 
of Amos to handle missing data. Or maybe you want to use the bootstrapping capability 
of Amos, particularly to obtain confidence intervals.

Examples 5 through 8 illustrate the basic techniques that are commonly used 
nowadays in structural modeling. 
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Example 9 and those that follow demonstrate advanced techniques that have so far not 
been used as much as they deserve. These techniques include: 

Simultaneous analysis of data from several different populations. 

Estimation of means and intercepts in regression equations.

Maximum likelihood estimation in the presence of missing data. 

Bootstrapping to obtain estimated standard errors and confidence intervals. Amos 
makes these techniques especially easy to use, and we hope that they will become 
more commonplace.

Specification searches.

Bayesian estimation.

Imputation of missing values.

Analysis of censored data.

Analysis of ordered-categorical data.

Mixture modeling.

Tip: If you have questions about a particular Amos feature, you can always refer to the 
extensive online Help provided by the program. 

About the Documentation

Amos 19 comes with extensive documentation, including an online Help system, this 
user’s guide, and advanced reference material for Amos Basic and the Amos API 
(Application Programming Interface). If you performed a typical installation, you can 
find the Amos 19 Programming Reference Guide in the following location: 
C:\Program Files\IBM\SPSS\Amos\19\Documentation\Programming Reference.pdf.

Other Sources of Information

Although this user’s guide contains a good bit of expository material, it is not by any 
means a complete guide to the correct and effective use of structural modeling. Many 
excellent SEM textbooks are available.

Structural Equation Modeling: A Multidisciplinary Journal contains 
methodological articles as well as applications of structural modeling. It is 
published by:
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Lawrence Erlbaum Associates, Inc.
Journal Subscription Department
10 Industrial Avenue
Mahwah, NJ 07430-2262 USA
www.erlbaum.com

Carl Ferguson and Edward Rigdon established an electronic mailing list called 
Semnet to provide a forum for discussions related to structural modeling. You can 
find information about subscribing to Semnet at 
www.gsu.edu/~mkteer/semnet.html.

Edward Rigdon also maintains a list of frequently asked questions about structural 
equation modeling. That FAQ is located at www.gsu.edu/~mkteer/semfaq.html.
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Chapter

2
Tutorial: Getting Started with 
Amos Graphics

Introduction

Remember your first statistics class when you sweated through memorizing formulas 
and laboriously calculating answers with pencil and paper? The professor had you do 
this so that you would understand some basic statistical concepts. Later, you 
discovered that a calculator or software program could do all of these calculations in 
a split second.

This tutorial is a little like that early statistics class. There are many shortcuts to 
drawing and labeling path diagrams in Amos Graphics that you will discover as you 
work through the examples in this user’s guide or as you refer to the online Help. The 
intent of this tutorial is to simply get you started using Amos Graphics. It will cover 
some of the basic functions and features of Amos and guide you through your first 
Amos analysis. 

Once you have worked through the tutorial, you can learn about more advanced 
functions from the online Help, or you can continue to learn incrementally by working 
your way through the examples.

If you performed a typical installation, you can find the path diagram constructed 
in this tutorial in this location: 
C:\Program Files\IBM\SPSS\Amos\19\Tutorial\<language>. The file Startsps.amw 
uses a data file in SPSS Statistics format. Getstart.amw is the same path diagram but 
uses data from a Microsoft Excel file.

Tip: Amos 19 provides more than one way to accomplish most tasks. For all menu 
commands except Tools → Macro, there is a toolbar button that performs the same task. 
For many tasks, Amos also provides keyboard shortcuts. The user’s guide 
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demonstrates the menu path. For information about the toolbar buttons and keyboard 
shortcuts, see the online Help.

About the Data

Hamilton (1990) provided several measurements on each of 21 states. Three of the 
measurements will be used in this tutorial: 

Average SAT score

Per capita income expressed in $1,000 units 

Median education for residents 25 years of age or older

You can find the data in the Tutorial directory within the Excel 8.0 workbook 
Hamilton.xls in the worksheet named Hamilton. The data are as follows:

SAT Income Education

899 14.345 12.7
896 16.37 12.6
897 13.537 12.5
889 12.552 12.5
823 11.441 12.2
857 12.757 12.7
860 11.799 12.4
890 10.683 12.5
889 14.112 12.5
888 14.573 12.6
925 13.144 12.6
869 15.281 12.5
896 14.121 12.5
827 10.758 12.2
908 11.583 12.7
885 12.343 12.4
887 12.729 12.3
790 10.075 12.1
868 12.636 12.4
904 10.689 12.6
888 13.065 12.4
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The following path diagram shows a model for these data:

This is a simple regression model where one observed variable, SAT, is predicted as a 
linear combination of the other two observed variables, Education and Income. As with 
nearly all empirical data, the prediction will not be perfect. The variable Other 
represents variables other than Education and Income that affect SAT.

Each single-headed arrow represents a regression weight. The number 1 in the 
figure specifies that Other must have a weight of 1 in the prediction of SAT. Some such 
constraint must be imposed in order to make the model identified, and it is one of the 
features of the model that must be communicated to Amos.

Launching Amos Graphics

You can launch Amos Graphics in any of the following ways:

Click Start on the Windows task bar, and choose All Programs → IBM SPSS 
Statistics → IBM SPSS Amos 19 → Amos Graphics. 
Double-click any path diagram (*.amw).

Drag a path diagram (*.amw) file from Windows Explorer to the Amos Graphics 
window.

Click Start on the Windows task bar, and choose All Programs → IBM SPSS 
Statistics → IBM SPSS Amos 19 → View Path Diagrams. Then double-click a path 
diagram in the View Path Diagrams window.

From within SPSS Statistics, choose Add-ons → Applications → Amos from the 
menus.
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Creating a New Model

E From the menus, choose File → New. 

Your work area appears. The large area on the right is where you draw path diagrams. 
The toolbar on the left provides one-click access to the most frequently used buttons. 
You can use either the toolbar or menu commands for most operations.
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Specifying the Data File

The next step is to specify the file that contains the Hamilton data. This tutorial uses a 
Microsoft Excel 8.0 (*.xls) file, but Amos supports several common database formats, 
including SPSS Statistics *.sav files. If you launch Amos from the Add-ons menu in 
SPSS Statistics, Amos automatically uses the file that is open in SPSS Statistics. 

E From the menus, choose File → Data Files.

E In the Data Files dialog box, click File Name.

E Browse to the Tutorial folder. If you performed a typical installation, the path is 
C:\Program Files\IBM\SPSS\Amos\19\Tutorial\<language>.

E In the Files of type list, select Excel 8.0 (*.xls). 

E Select Hamilton.xls, and then click Open. 

E In the Data Files dialog box, click OK. 

Specifying the Model and Drawing Variables

The next step is to draw the variables in your model. First, you’ll draw three rectangles 
to represent the observed variables, and then you’ll draw an ellipse to represent the 
unobserved variable. 

E From the menus, choose Diagram → Draw Observed.

E In the drawing area, move your mouse pointer to where you want the Education 
rectangle to appear. Click and drag to draw the rectangle. Don’t worry about the exact 
size or placement of the rectangle because you can change it later. 

E Use the same method to draw two more rectangles for Income and SAT. 

E From the menus, choose Diagram → Draw Unobserved.
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E In the drawing area, move your mouse pointer to the right of the three rectangles and 
click and drag to draw the ellipse. 

The model in your drawing area should now look similar to the following:

Naming the Variables

E In the drawing area, right-click the top left rectangle and choose Object Properties from 
the pop-up menu. 

E Click the Text tab.

E In the Variable name text box, type Education.

E Use the same method to name the remaining variables. Then close the Object 
Properties dialog box. 
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Your path diagram should now look like this:

Drawing Arrows

Now you will add arrows to the path diagram, using the following model as your guide:

 

E From the menus, choose Diagram → Draw Path.

E Click and drag to draw an arrow between Education and SAT. 

E Use this method to add each of the remaining single-headed arrows. 

E From the menus, choose Diagram → Draw Covariances.

E Click and drag to draw a double-headed arrow between Income and Education. Don’t 
worry about the curve of the arrow because you can adjust it later.
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Constraining a Parameter

To identify the regression model, you must define the scale of the latent variable Other. 
You can do this by fixing either the variance of Other or the path coefficient from Other 
to SAT at some positive value. The following shows you how to fix the path coefficient 
at unity (1). 

E In the drawing area, right-click the arrow between Other and SAT and choose Object 
Properties from the pop-up menu.

E Click the Parameters tab.

E In the Regression weight text box, type 1. 

E Close the Object Properties dialog box. 

There is now a 1 above the arrow between Other and SAT. Your path diagram is now 
complete, other than any changes you may wish to make to its appearance. It should 
look something like this: 
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Altering the Appearance of a Path Diagram

You can change the appearance of your path diagram by moving and resizing objects. 
These changes are visual only; they do not affect the model specification. 

To Move an Object

E From the menus, choose Edit → Move.

E In the drawing area, click and drag the object to its new location.

To Reshape an Object or Double-Headed Arrow

E From the menus, choose Edit → Shape of Object.

E In the drawing area, click and drag the object until you are satisfied with its size and 
shape.

To Delete an Object

E From the menus, choose Edit → Erase.

E In the drawing area, click the object you wish to delete. 
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To Undo an Action

E From the menus, choose Edit → Undo.

To Redo an Action

E From the menus, choose Edit → Redo.

Setting Up Optional Output

Some of the output in Amos is optional. In this step, you will choose which portions of 
the optional output you want Amos to display after the analysis. 

E From the menus, choose View → Analysis Properties.

E Click the Output tab.

E Select the Minimization history, Standardized estimates, and Squared multiple correlations 
check boxes.
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E Close the Analysis Properties dialog box. 
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Performing the Analysis

The only thing left to do is perform the calculations for fitting the model. Note that in 
order to keep the parameter estimates up to date, you must do this every time you 
change the model, the data, or the options in the Analysis Properties dialog box.

E From the menus, click Analyze → Calculate Estimates. 

E Because you have not yet saved the file, the Save As dialog box appears. Type a name 
for the file and click Save. 

Amos calculates the model estimates. The panel to the left of the path diagram displays 
a summary of the calculations.

Viewing Output

When Amos has completed the calculations, you have two options for viewing the 
output: text and graphics.

To View Text Output

E From the menus, choose View → Text Output.

The tree diagram in the upper left pane of the Amos Output window allows you to 
choose a portion of the text output for viewing.

E Click Estimates to view the parameter estimates.
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To View Graphics Output

E Click the Show the output path diagram button .

E In the Parameter Formats pane to the left of the drawing area, click Standardized 
estimates.
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Your path diagram now looks like this:

 

The value 0.49 is the correlation between Education and Income. The values 0.72 and 
0.11 are standardized regression weights. The value 0.60 is the squared multiple 
correlation of SAT with Education and Income.

E In the Parameter Formats pane to the left of the drawing area, click Unstandardized 

estimates.

Your path diagram should now look like this:

 

Printing the Path Diagram

E From the menus, choose File → Print.

The Print dialog box appears. 
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E Click Print.

Copying the Path Diagram

Amos Graphics lets you easily export your path diagram to other applications such as 
Microsoft Word. 

E From the menus, choose Edit → Copy (to Clipboard).

E Switch to the other application and use the Paste function to insert the path diagram. 
Amos Graphics exports only the diagram; it does not export the background.

Copying Text Output

E In the Amos Output window, select the text you want to copy. 

E Right-click the selected text, and choose Copy from the pop-up menu.

E Switch to the other application and use the Paste function to insert the text.
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Example

1
Estimating Variances and 
Covariances

Introduction 

This example shows you how to estimate population variances and covariances. It also 
discusses the general format of Amos input and output.

About the Data

Attig (1983) showed 40 subjects a booklet containing several pages of advertisements. 
Then each subject was given three memory performance tests.

Attig repeated the study with the same 40 subjects after a training exercise intended 
to improve memory performance. There were thus three performance measures 
before training and three performance measures after training. In addition, she 
recorded scores on a vocabulary test, as well as age, sex, and level of education. 
Attig’s data files are included in the Examples folder provided by Amos.

Test Explanation

recall
The subject was asked to recall as many of the advertisements as possible. 
The subject’s score on this test was the number of advertisements recalled 
correctly.

cued
The subject was given some cues and asked again to recall as many of the 
advertisements as possible. The subject’s score was the number of 
advertisements recalled correctly.

place

The subject was given a list of the advertisements that appeared in the 
booklet and was asked to recall the page location of each one. The subject’s 
score on this test was the number of advertisements whose location was 
recalled correctly.
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Bringing In the Data

E From the menus, choose File → New. 

E From the menus, choose File → Data Files.

E In the Data Files dialog box, click File Name.

E Browse to the Examples folder. If you performed a typical installation, the path is 
C:\Program Files\IBM\SPSS\Amos\19\Examples\<language>.

E In the Files of type list, select Excel 8.0 (*.xls), select UserGuide.xls, and then click 
Open. 

E In the Data Files dialog box, click OK. 

Amos displays a list of worksheets in the UserGuide workbook. The worksheet 
Attg_yng contains the data for this example.

E In the Select a Data Table dialog box, select Attg_yng, then click View Data.

 

The Excel worksheet for the Attg_yng data file opens.
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As you scroll across the worksheet, you will see all of the test variables from the Attig 
study. This example uses only the following variables: recall1 (recall pretest), recall2 
(recall posttest), place1 (place recall pretest), and place2 (place recall posttest).

E After you review the data, close the data window. 

E In the Data Files dialog box, click OK.

Analyzing the Data

In this example, the analysis consists of estimating the variances and covariances of the 
recall and place variables before and after training. 

Specifying the Model

E From the menus, choose Diagram → Draw Observed.

E In the drawing area, move your mouse pointer to where you want the first rectangle to 
appear. Click and drag to draw the rectangle. 

E From the menus, choose Edit → Duplicate.

E Click and drag a duplicate from the first rectangle. Release the mouse button to 
position the duplicate.
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E Create two more duplicate rectangles until you have four rectangles side by side. 

Tip: If you want to reposition a rectangle, choose Edit → Move from the menus and drag 
the rectangle to its new position.

 

Naming the Variables

E From the menus, choose View → Variables in Dataset.

The Variables in Dataset dialog box appears.

 

E Click and drag the variable recall1 from the list to the first rectangle in the drawing 
area.

E Use the same method to name the variables recall2, place1, and place2. 

E Close the Variables in Dataset dialog box.
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Changing the Font

E Right-click a variable and choose Object Properties from the pop-up menu. 

The Object Properties dialog box appears.

E Click the Text tab and adjust the font attributes as desired. 

Establishing Covariances

If you leave the path diagram as it is, Amos Graphics will estimate the variances of the 
four variables, but it will not estimate the covariances between them. In Amos 
Graphics, the rule is to assume a correlation or covariance of 0 for any two variables 
that are not connected by arrows. To estimate the covariances between the observed 
variables, we must first connect all pairs with double-headed arrows. 

E From the menus, choose Diagram → Draw Covariances.

E Click and drag to draw arrows that connect each variable to every other variable. 

Your path diagram should have six double-headed arrows.
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Performing the Analysis

E From the menus, choose Analyze → Calculate Estimates. 

Because you have not yet saved the file, the Save As dialog box appears.

E Enter a name for the file and click Save. 

Viewing Graphics Output

E Click the Show the output path diagram button .

Amos displays the output path diagram with parameter estimates.
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In the output path diagram, the numbers displayed next to the boxes are estimated 
variances, and the numbers displayed next to the double-headed arrows are estimated 
covariances. For example, the variance of recall1 is estimated at 5.79, and that of 
place1 at 33.58. The estimated covariance between these two variables is 4.34.

Viewing Text Output

E From the menus, choose View → Text Output.

E In the tree diagram in the upper left pane of the Amos Output window, click Estimates.

The first estimate displayed is of the covariance between recall1 and recall2. The 
covariance is estimated to be 2.56. Right next to that estimate, in the S.E. column, is an 
estimate of the standard error of the covariance, 1.16. The estimate 2.56 is an 

_Ref76537719
_Ref76537719
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observation on an approximately normally distributed random variable centered 
around the population covariance with a standard deviation of about 1.16, that is, if the 
assumptions in the section “Distribution Assumptions for Amos Models” on p. 35 are 
met. For example, you can use these figures to construct a 95% confidence interval on 
the population covariance by computing . Later, you 
will see that you can use Amos to estimate many kinds of population parameters 
besides covariances and can follow the same procedure to set a confidence interval on 
any one of them.

Next to the standard error, in the C.R. column, is the critical ratio obtained by 
dividing the covariance estimate by its standard error . This ratio 
is relevant to the null hypothesis that, in the population from which Attig’s 40 subjects 
came, the covariance between recall1 and recall2 is 0. If this hypothesis is true, and 
still under the assumptions in the section “Distribution Assumptions for Amos 
Models” on p. 35, the critical ratio is an observation on a random variable that has an 
approximate standard normal distribution. Thus, using a significance level of 0.05, any 
critical ratio that exceeds 1.96 in magnitude would be called significant. In this 
example, since 2.20 is greater than 1.96, you would say that the covariance between 
recall1 and recall2 is significantly different from 0 at the 0.05 level.

The P column, to the right of C.R., gives an approximate two-tailed p value for 
testing the null hypothesis that the parameter value is 0 in the population. The table 
shows that the covariance between recall1 and recall2 is significantly different from 0 
with . The calculation of P assumes that parameter estimates are normally 
distributed, and it is correct only in large samples. See Appendix A for more 
information.

The assertion that the parameter estimates are normally distributed is only an 
approximation. Moreover, the standard errors reported in the S.E. column are only 
approximations and may not be the best available. Consequently, the confidence 
interval and the hypothesis test just discussed are also only approximate. This is 
because the theory on which these results are based is asymptotic. Asymptotic means 
that it can be made to apply with any desired degree of accuracy, but only by using a 
sufficiently large sample. We will not discuss whether the approximation is 
satisfactory with the present sample size because there would be no way to generalize 
the conclusions to the many other kinds of analyses that you can do with Amos. 
However, you may want to re-examine the null hypothesis that recall1 and recall2 are 
uncorrelated, just to see what is meant by an approximate test. We previously 
concluded that the covariance is significantly different from 0 because 2.20 exceeds 
1.96. The p value associated with a standard normal deviate of 2.20 is 0.028 (two-
tailed), which, of course, is less than 0.05. By contrast, the conventional t statistic (for 

2.56 1.96 1.160 2.56 2.27±=×±

2.20 2.56 1.16⁄=( )

p 0.03=
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example, Runyon and Haber, 1980, p. 226) is 2.509 with 38 degrees of freedom 
. In this example, both p values are less than 0.05, so both tests agree in 

rejecting the null hypothesis at the 0.05 level. However, in other situations, the two 
p values might lie on opposite sides of 0.05. You might or might not regard this as 
especially serious—at any rate, the two tests can give different results. There should be 
no doubt about which test is better. The t test is exact under the assumptions of 
normality and independence of observations, no matter what the sample size. In Amos, 
the test based on critical ratio depends on the same assumptions; however, with a finite 
sample, the test is only approximate.

Note: For many interesting applications of Amos, there is no exact test or exact standard 
error or exact confidence interval available.

On the bright side, when fitting a model for which conventional estimates exist, 
maximum likelihood point estimates (for example, the numbers in the Estimate 
column) are generally identical to the conventional estimates.

E Now click Notes for Model in the upper left pane of the Amos Output window.

The following table plays an important role in every Amos analysis:

Number of distinct sample moments: 10
Number of distinct parameters to be estimated: 10

Degrees of freedom (10 – 10): 0

p 0.016=( )
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The Number of distinct sample moments referred to are sample means, variances, and 
covariances. In most analyses, including the present one, Amos ignores means, so that 
the sample moments are the sample variances of the four variables, recall1, recall2, 
place1, and place2, and their sample covariances. There are four sample variances and 
six sample covariances, for a total of 10 sample moments. 

The Number of distinct parameters to be estimated are the corresponding 
population variances and covariances. There are, of course, four population variances 
and six population covariances, which makes 10 parameters to be estimated. 

The Degrees of freedom is the amount by which the number of sample moments 
exceeds the number of parameters to be estimated. In this example, there is a one-to-
one correspondence between the sample moments and the parameters to be estimated, 
so it is no accident that there are zero degrees of freedom.

As we will see beginning with Example 2, any nontrivial null hypothesis about the 
parameters reduces the number of parameters that have to be estimated. The result will 
be positive degrees of freedom. For now, there is no null hypothesis being tested. 
Without a null hypothesis to test, the following table is not very interesting:

If there had been a hypothesis under test in this example, the chi-square value would have 
been a measure of the extent to which the data were incompatible with the hypothesis. A 
chi-square value of 0 would ordinarily indicate no departure from the null hypothesis. 
But in the present example, the 0 value for degrees of freedom and the 0 chi-square value 
merely reflect the fact that there was no null hypothesis in the first place.

This line indicates that Amos successfully estimated the variances and covariances. 
Sometimes structural modeling programs like Amos fail to find estimates. Usually, 
when Amos fails, it is because you have posed a problem that has no solution, or no 
unique solution. For example, if you attempt maximum likelihood estimation with 
observed variables that are linearly dependent, Amos will fail because such an analysis 
cannot be done in principle. Problems that have no unique solution are discussed 
elsewhere in this user’s guide under the subject of identifiability. Less commonly, 
Amos can fail because an estimation problem is just too difficult. The possibility of 
such failures is generic to programs for analysis of moment structures. Although the 
computational method used by Amos is highly effective, no computer program that 
does the kind of analysis that Amos does can promise success in every case.

Chi-square = 0.00
Degrees of freedom = 0
Probability level cannot be computed

Minimum was achieved
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Optional Output

So far, we have discussed output that Amos generates by default. You can also request 
additional output. 

Calculating Standardized Estimates

You may be surprised to learn that Amos displays estimates of covariances rather than 
correlations. When the scale of measurement is arbitrary or of no substantive interest, 
correlations have more descriptive meaning than covariances. Nevertheless, Amos and 
similar programs insist on estimating covariances. Also, as will soon be seen, Amos 
provides a simple method for testing hypotheses about covariances but not about 
correlations. This is mainly because it is easier to write programs that way. On the other 
hand, it is not hard to derive correlation estimates after the relevant variances and 
covariances have been estimated. To calculate standardized estimates:

E From the menus, choose View → Analysis Properties.

E In the Analysis Properties dialog box, click the Output tab.

E Select the Standardized estimates check box.

 

E Close the Analysis Properties dialog box.
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Rerunning the Analysis

Because you have changed the options in the Analysis Properties dialog box, you must 
rerun the analysis. 

E From the menus, choose Analyze → Calculate Estimates. 

E Click the Show the output path diagram button. 

E In the Parameter Formats pane to the left of the drawing area, click Standardized 

estimates.

Viewing Correlation Estimates as Text Output

E From the menus, choose View → Text Output.



35

Estimating Variances and Covariance s

E In the tree diagram in the upper left pane of the Amos Output window, expand 
Estimates, Scalars, and then click Correlations. 

Distribution Assumptions for Amos Models

Hypothesis testing procedures, confidence intervals, and claims for efficiency in 
maximum likelihood or generalized least-squares estimation depend on certain 
assumptions. First, observations must be independent. For example, the 40 young 
people in the Attig study have to be picked independently from the population of young 
people. Second, the observed variables must meet some distributional requirements. If 
the observed variables have a multivariate normal distribution, that will suffice. 
Multivariate normality of all observed variables is a standard distribution assumption 
in many structural equation modeling and factor analysis applications.

There is another, more general, situation under which maximum likelihood 
estimation can be carried out. If some exogenous variables are fixed (that is, they are 
either known beforehand or measured without error), their distributions may have any 
shape, provided that:

For any value pattern of the fixed variables, the remaining (random) variables have 
a (conditional) normal distribution.

The (conditional) variance-covariance matrix of the random variables is the same 
for every pattern of the fixed variables.
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The (conditional) expected values of the random variables depend linearly on the 
values of the fixed variables.

A typical example of a fixed variable would be an experimental treatment, classifying 
respondents into a study group and a control group, respectively. It is all right that 
treatment is non-normally distributed, as long as the other exogenous variables are 
normally distributed for study and control cases alike, and with the same conditional 
variance-covariance matrix. Predictor variables in regression analysis (see Example 4) 
are often regarded as fixed variables.

Many people are accustomed to the requirements for normality and independent 
observations, since these are the usual requirements for many conventional procedures. 
However, with Amos, you have to remember that meeting these requirements leads 
only to asymptotic conclusions (that is, conclusions that are approximately true for 
large samples).

Modeling in VB.NET

It is possible to specify and fit a model by writing a program in VB.NET or in C#. Writing 
programs is an alternative to using Amos Graphics to specify a model by drawing its path 
diagram. This section shows how to write a VB.NET program to perform the analysis of 
Example 1. A later section explains how to do the same thing in C#. 

Amos comes with its own built-in editor for VB.NET and C# programs. It is 
accessible from the Windows Start menu. To begin Example 1 using the built-in editor:

E From the Windows Start menu, choose All Programs → IBM SPSS Statistics →
IBM SPSS Amos 19 → Program Editor.

E In the Program Editor window, choose File → New VB Program.
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E Enter the VB.NET code for specifying and fitting the model in place of the ‘Your code 

goes here comment. The following figure shows the program editor after the complete 
program has been entered.

Note: The Examples directory contains all of the pre-written examples. 
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To open the VB.NET file for the present example:

E From the Program Editor menus, choose File → Open.

E Select the file Ex01.vb in the \Amos\19\Examples\<language> directory.

The following table gives a line-by-line explanation of the program.

E To perform the analysis, from the menus, choose File → Run.

Program Statement Explanation

Dim Sem As New AmosEngine

Declares Sem as an object of type 
AmosEngine. The methods and properties of 
the Sem object are used to specify and fit the 
model.

Sem.TextOutput

Creates an output file containing the results of 
the analysis. At the end of the analysis, the 
contents of the output file are displayed in a 
separate window.

Sem.BeginGroup …

Begins the model specification for a single 
group (that is, a single population). This line 
also specifies that the Attg_yng worksheet in the 
Excel workbook UserGuide.xls contains the 
input data. Sem.AmosDir() is the location of the 
Amos program directory.

Sem.AStructure("recall1")
Sem.AStructure("recall2")
Sem.AStructure("place1")
Sem.AStructure("place2")

Specifies the model. The four AStructure 
statements declare the variances of recall1, 
recall2, place1, and place2 to be free 
parameters. The other eight variables in the 
Attg_yng data file are left out of this analysis. In 
an Amos program (but not in Amos Graphics), 
observed exogenous variables are assumed by 
default to be correlated, so that Amos will 
estimate the six covariances among the four 
variables.

Sem.FitModel() Fits the model.

Sem.Dispose()

Releases resources used by the Sem object. It is 
particularly important for your program to use 
an AmosEngine object’s Dispose method before 
creating another AmosEngine object. A process 
is allowed only one instance of an AmosEngine 
object at a time.

Try/Finally/End Try
The Try block guarantees that the Dispose 
method will be called even if an error occurs 
during program execution.
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Generating Additional Output

Some AmosEngine methods generate additional output. For example, the Standardized 
method displays standardized estimates. The following figure shows the use of the 
Standardized method:

Modeling in C#

Writing an Amos program in C# is similar to writing one in VB.NET. To start a new 
C# program, in the built-in program editor of Amos:

E Choose File → New C# Program (rather than File → New VB Program).

E Choose File → Open to open Ex01.cs, which is a C# version of the VB.NET program 
Ex01.vb.
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Other Program Development Tools

The built-in program editor in Amos is used throughout this user’s guide for writing 
and executing Amos programs. However, you can use the development tool of your 
choice. The Examples folder contains a VisualStudio subfolder where you can find 
Visual Studio VB.NET and C# solutions for Example 1.
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2
Testing Hypotheses

Introduction

This example demonstrates how you can use Amos to test simple hypotheses about 
variances and covariances. It also introduces the chi-square test for goodness of fit and 
elaborates on the concept of degrees of freedom.

About the Data

We will use Attig’s (1983) spatial memory data, which were described in Example 1. 
We will also begin with the same path diagram as in Example 1. To demonstrate the 
ability of Amos to use different data formats, this example uses a data file in SPSS 
Statistics format instead of an Excel file. 

Parameters Constraints

The following is the path diagram from Example 1. We can think of the variable 
objects as having small boxes nearby (representing the variances) that are filled in 
once Amos has estimated the parameters. 
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You can fill these boxes yourself instead of letting Amos fill them.

Constraining Variances

Suppose you want to set the variance of recall1 to 6 and the variance of recall2 to 8. 

E In the drawing area, right-click recall1 and choose Object Properties from the pop-up 
menu.

E Click the Parameters tab.

E In the Variance text box, type 6.

E With the Object Properties dialog box still open, click recall2 and set its variance to 8. 
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E Close the dialog box.

The path diagram displays the parameter values you just specified.

This is not a very realistic example because the numbers 6 and 8 were just picked out 
of the air. Meaningful parameter constraints must have some underlying rationale, 
perhaps being based on theory or on previous analyses of similar data.

Specifying Equal Parameters

Sometimes you will be interested in testing whether two parameters are equal in the 
population. You might, for example, think that the variances of recall1 and recall2 
might be equal without having a particular value for the variances in mind. To 
investigate this possibility, do the following: 

E In the drawing area, right-click recall1 and choose Object Properties from the pop-up 
menu. 

E Click the Parameters tab.

E In the Variance text box, type v_recall.

E Click recall2 and label its variance as v_recall.

E Use the same method to label the place1 and place2 variances as v_place.

It doesn’t matter what label you use. The important thing is to enter the same label for 
each variance you want to force to be equal. The effect of using the same label is to 
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require both of the variances to have the same value without specifying ahead of time 
what that value is.

Benefits of Specifying Equal Parameters

Before adding any further constraints on the model parameters, let’s examine why we 
might want to specify that two parameters, like the variances of recall1 and recall2 or 
place1 and place2, are equal. Here are two benefits:

If you specify that two parameters are equal in the population and if you are correct 
in this specification, then you will get more accurate estimates, not only of the 
parameters that are equal but usually of the others as well. This is the only benefit 
if you happen to know that the parameters are equal.

If the equality of two parameters is a mere hypothesis, requiring their estimates to 
be equal will result in a test of that hypothesis. 

Constraining Covariances

Your model may also include restrictions on parameters other than variances. For 
example, you may hypothesize that the covariance between recall1 and place1 is equal 
to the covariance between recall2 and place2. To impose this constraint: 

E In the drawing area, right-click the double-headed arrow that connects recall1 and 
place1, and choose Object Properties from the pop-up menu. 

E Click the Parameters tab.

E In the Covariance text box, type a non-numeric string such as cov_rp.

E Use the same method to set the covariance between recall2 and place2 to cov_rp.
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Moving and Formatting Objects

While a horizontal layout is fine for small examples, it is not practical for analyses that 
are more complex. The following is a different layout of the path diagram on which 
we’ve been working:
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You can use the following tools to rearrange your path diagram until it looks like the 
one above: 

To move objects, choose Edit → Move from the menus, and then drag the object to 
its new location. You can also use the Move button to drag the endpoints of arrows. 

To copy formatting from one object to another, choose Edit → Drag Properties from 
the menus, select the properties you wish to apply, and then drag from one object 
to another. 

For more information about the Drag Properties feature, refer to online Help. 

Data Input

This example uses a data file in SPSS Statistics format. If you have SPSS Statistics 
installed, you can view the data as you load it. Even if you don’t have SPSS Statistics 
installed, Amos will still read the data. 

E From the menus, choose File → Data Files.

E In the Data Files dialog box, click File Name.

E Browse to the Examples folder. If you performed a typical installation, the path is 
C:\Program Files\IBM\SPSS\Amos\19\Examples\<language>.

E In the Files of type list, select SPSS Statistics (*.sav), click Attg_yng, and then click 
Open. 

E If you have SPSS Statistics installed, click the View Data button in the Data Files dialog 
box. An SPSS Statistics window opens and displays the data.
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E Review the data and close the data view.

E In the Data Files dialog box, click OK.

Performing the Analysis

E From the menus, choose Analyze → Calculate Estimates. 

E In the Save As dialog box, enter a name for the file and click Save. 

Amos calculates the model estimates. 

Viewing Text Output

E From the menus, choose View → Text Output. 

E To view the parameter estimates, click Estimates in the tree diagram in the upper left 
pane of the Amos Output window.
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You can see that the parameters that were specified to be equal do have equal 
estimates. The standard errors here are generally smaller than the standard errors 
obtained in Example 1. Also, because of the constraints on the parameters, there are 
now positive degrees of freedom. 

E Now click Notes for Model in the upper left pane of the Amos Output window.

While there are still 10 sample variances and covariances, the number of parameters to 
be estimated is only seven. Here is how the number seven is arrived at: The variances 
of recall1 and recall2, labeled v_recall, are constrained to be equal, and thus count as 
a single parameter. The variances of place1 and place2 (labeled v_place) count as 
another single parameter. A third parameter corresponds to the equal covariances 
recall1 <> place1 and recall2 <> place2 (labeled cov_rp). These three parameters, 
plus the four unlabeled, unrestricted covariances, add up to seven parameters that have 
to be estimated.

The degrees of freedom ( ) may also be thought of as the number of 
constraints placed on the original 10 variances and covariances.

Optional Output

The output we just discussed is all generated by default. You can also request additional 
output:

E From the menus, choose View → Analysis Properties.

E Click the Output tab.

E Ensure that the following check boxes are selected: Minimization history, Standardized 

estimates, Sample moments, Implied moments, and Residual moments.

10 7 3=–
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E From the menus, choose Analyze → Calculate Estimates. 

Amos recalculates the model estimates.

Covariance Matrix Estimates

E To see the sample variances and covariances collected into a matrix, choose View → 

Text Output from the menus.

E Click Sample Moments in the tree diagram in the upper left corner of the Amos Output 
window. 
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The following is the sample covariance matrix:

E In the tree diagram, expand Estimates and then click Matrices. 

The following is the matrix of implied covariances:

 

Note the differences between the sample and implied covariance matrices. Because the 
model imposes three constraints on the covariance structure, the implied variances and 
covariances are different from the sample values. For example, the sample variance of 
place1 is 33.58, but the implied variance is 27.53. To obtain a matrix of residual 
covariances (sample covariances minus implied covariances), put a check mark next to 
Residual moments on the Output tab and repeat the analysis.

The following is the matrix of residual covariances:
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Displaying Covariance and Variance Estimates on the Path Diagram

As in Example 1, you can display the covariance and variance estimates on the path 
diagram. 

E Click the Show the output path diagram button. 

E In the Parameter Formats pane to the left of the drawing area, click Unstandardized 

estimates. Alternatively, you can request correlation estimates in the path diagram by 
clicking Standardized estimates.

The following is the path diagram showing correlations:

Labeling Output

It may be difficult to remember whether the displayed values are covariances or 
correlations. To avoid this problem, you can use Amos to label the output. 

E Open the file Ex02.amw. 

E Right-click the caption at the bottom of the path diagram, and choose Object Properties 
from the pop-up menu.

E Click the Text tab.
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Notice the word \format in the bottom line of the figure caption. Words that begin with 
a backward slash, like \format, are called text macros. Amos replaces text macros with 
information about the currently displayed model. The text macro \format will be 
replaced by the heading Model Specification, Unstandardized estimates, or 
Standardized estimates, depending on which version of the path diagram is displayed.

Hypothesis Testing

The implied covariances are the best estimates of the population variances and 
covariances under the null hypothesis. (The null hypothesis is that the parameters 
required to have equal estimates are truly equal in the population.) As we know from 
Example 1, the sample covariances are the best estimates obtained without making any 
assumptions about the population values. A comparison of these two matrices is 
relevant to the question of whether the null hypothesis is correct. If the null hypothesis 
is correct, both the implied and sample covariances are maximum likelihood estimates 
of the corresponding population values (although the implied covariances are better 
estimates). Consequently, you would expect the two matrices to resemble each other. 
On the other hand, if the null hypothesis is wrong, only the sample covariances are 
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maximum likelihood estimates, and there is no reason to expect them to resemble the 
implied covariances.

The chi-square statistic is an overall measure of how much the implied covariances 
differ from the sample covariances.

In general, the more the implied covariances differ from the sample covariances, the 
bigger the chi-square statistic will be. If the implied covariances had been identical to 
the sample covariances, as they were in Example 1, the chi-square statistic would have 
been 0. You can use the chi-square statistic to test the null hypothesis that the 
parameters required to have equal estimates are really equal in the population. 
However, it is not simply a matter of checking to see if the chi-square statistic is 0. 
Since the implied covariances and the sample covariances are merely estimates, you 
can’t expect them to be identical (even if they are both estimates of the same population 
covariances). Actually, you would expect them to differ enough to produce a chi-square 
in the neighborhood of the degrees of freedom, even if the null hypothesis is true. In 
other words, a chi-square value of 3 would not be out of the ordinary here, even with a 
true null hypothesis. You can say more than that: If the null hypothesis is true, the chi-
square value (6.276) is a single observation on a random variable that has an 
approximate chi-square distribution with three degrees of freedom. The probability is 
about 0.099 that such an observation would be as large as 6.276. Consequently, the 
evidence against the null hypothesis is not significant at the 0.05 level.

Displaying Chi-Square Statistics on the Path Diagram

You can get the chi-square statistic and its degrees of freedom to appear in a figure 
caption on the path diagram using the text macros \cmin and \df. Amos replaces these 
text macros with the numeric values of the chi-square statistic and its degrees of 
freedom. You can use the text macro \p to display the corresponding right-tail 
probability under the chi-square distribution. 

E From the menus, choose Diagram → Figure Caption. 

E Click the location on the path diagram where you want the figure caption to appear. 

The Figure Caption dialog box appears.

Chi-square = 6.276
Degrees of freedom = 3
Probability level = 0.099
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E In the Figure Caption dialog box, enter a caption that includes the \cmin, \df, and \p text 
macros, as follows:

When Amos displays the path diagram containing this caption, it appears as follows:
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Modeling in VB.NET

The following program fits the constrained model of Example 2:
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This table gives a line-by-line explanation of the program:

Program Statement Explanation

Dim Sem As New AmosEngine

Declares Sem as an object of type 
AmosEngine. The methods and 
properties of the Sem object are used to 
specify and fit the model.

Sem.TextOutput

Creates an output file containing the 
results of the analysis. At the end of the 
analysis, the contents of the output file 
are displayed in a separate window.

Sem.Standardized()
Sem.ImpliedMoments()
Sem.SampleMoments()
Sem.ResidualMoments()

Displays standardized estimates, implied 
covariances, sample covariances, and 
residual covariances.

Sem.BeginGroup …

Begins the model specification for a 
single group (that is, a single 
population). This line also specifies that 
the SPSS Statistics file Attg_yng.sav 
contains the input data. Sem.AmosDir() 
is the location of the Amos program 
directory.

Sem.AStructure("recall1 (v_recall)")
Sem.AStructure("recall2 (v_recall)")
Sem.AStructure("place1 (v_place)")
Sem.AStructure("place2 (v_place)")
Sem.AStructure("recall1 <> place1 (cov_rp)")
Sem.AStructure("recall2 <> place2 (cov_rp)")

Specifies the model. The first four 
AStructure statements constrain the 
variances of the observed variables 
through the use of parameter names in 
parentheses. Recall1 and recall2 are 
required to have the same variance 
because both variances are labeled 
v_recall. The variances of place1 and 
place2 are similarly constrained to be 
equal. Each of the last two AStructure 
lines represents a covariance. The two 
covariances are both named cov_rp. 
Consequently, those covariances are 
constrained to be equal.

Sem.FitModel() Fits the model.

Sem.Dispose()

Releases resources used by the Sem 
object. It is particularly important for 
your program to use an AmosEngine 
object’s Dispose method before creating 
another AmosEngine object. A process is 
allowed to have only one instance of an 
AmosEngine object at a time.

Try/Finally/End Try
This Try block guarantees that the 
Dispose method will be called even if an 
error occurs during program execution.
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E To perform the analysis, from the menus, choose File → Run.

Timing Is Everything

The AStructure lines must appear after BeginGroup; otherwise, Amos will not recognize 
that the variables named in the AStructure lines are observed variables in the 
attg_yng.sav dataset.

In general, the order of statements matters in an Amos program. In organizing an 
Amos program, AmosEngine methods can be divided into three general groups1.

Group 1 — Declarative Methods

This group contains methods that tell Amos what results to compute and display. 
TextOutput is a Group 1 method, as are Standardized, ImpliedMoments, SampleMoments, 
and ResidualMoments. Many other Group 1 methods that are not used in this example 
are documented in the Amos 19 Programming Reference Guide.

Group 2 — Data and Model Specification Methods

This group consists of data description and model specification commands. 
BeginGroup and AStructure are Group 2 methods. Others are documented in the Amos 
19 Programming Reference Guide.

Group 3 — Methods for Retrieving Results

These are commands to…well, retrieve results. So far, we have not used any Group 3 
methods. Examples using Group 3 methods are given in the Amos 19 Programming 
Reference Guide.

Tip: When you write an Amos program, it is important to pay close attention to the 
order in which you call the Amos engine methods. The rule is that groups must appear 
in order: Group 1, then Group 2, and finally Group 3.

For more detailed information about timing rules and a complete listing of methods and 
their group membership, see the Amos 19 Programming Reference Guide.

1 There is also a fourth special group, consisting of only the Initialize Method. If the optional Initialize Method 
is used, it must come before the Group 1 methods.
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3
More Hypothesis Testing

Introduction

This example demonstrates how to test the null hypothesis that two variables are 
uncorrelated, reinforces the concept of degrees of freedom, and demonstrates, in a 
concrete way, what is meant by an asymptotically correct test.

About the Data

For this example, we use the group of older subjects from Attig’s (1983) spatial 
memory study and the two variables age and vocabulary. We will use data formatted 
as a tab-delimited text file.

Bringing In the Data

E From the menus, choose File → New.

E From the menus, choose File → Data Files.

E In the Data Files dialog box, select File Name.

E Browse to the Examples folder. If you performed a typical installation, the path is 
C:\Program Files\IBM\SPSS\Amos\19\Examples\<language>.
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E In the Files of type list, select Text (*.txt), select Attg_old.txt, and then click Open. 

E In the Data Files dialog box, click OK. 

Testing a Hypothesis That Two Variables Are Uncorrelated

Among Attig’s 40 old subjects, the sample correlation between age and vocabulary is 
–0.09 (not very far from 0). Is this correlation nevertheless significant? To find out, we 
will test the null hypothesis that, in the population from which these 40 subjects came, 
the correlation between age and vocabulary is 0. We will do this by estimating the 
variance-covariance matrix under the constraint that age and vocabulary are 
uncorrelated. 

Specifying the Model

Begin by drawing and naming the two observed variables, age and vocabulary, in the 
path diagram, using the methods you learned in Example 1.

Amos provides two ways to specify that the covariance between age and vocabulary 
is 0. The most obvious way is simply to not draw a double-headed arrow connecting 
the two variables. The absence of a double-headed arrow connecting two exogenous 
variables implies that they are uncorrelated. So, without drawing anything more, the 
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model specified by the simple path diagram above specifies that the covariance (and 
thus the correlation) between age and vocabulary is 0.

The second method of constraining a covariance parameter is the more general 
procedure introduced in Example 1 and Example 2.

E From the menus, choose Diagram → Draw Covariances.

E Click and drag to draw an arrow that connects vocabulary and age. 

E Right-click the arrow and choose Object Properties from the pop-up menu. 

E Click the Parameters tab.

E Type 0 in the Covariance text box.

E Close the Object Properties dialog box. 

Your path diagram now looks like this:



62

Example 3

E From the menus, choose Analyze → Calculate Estimates.

The Save As dialog box appears.

E Enter a name for the file and click Save. 

Amos calculates the model estimates. 

Viewing Text Output

E From the menus, choose View → Text Output.

E In the tree diagram in the upper left pane of the Amos Output window, click Estimates.

Although the parameter estimates are not of primary interest in this analysis, they are 
as follows: 

In this analysis, there is one degree of freedom, corresponding to the single constraint 
that age and vocabulary be uncorrelated. The degrees of freedom can also be arrived 
at by the computation shown in the following text. To display this computation:

E Click Notes for Model in the upper left pane of the Amos Output window.
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The three sample moments are the variances of age and vocabulary and their 
covariance. The two distinct parameters to be estimated are the two population 
variances. The covariance is fixed at 0 in the model, not estimated from the sample 
information.

Viewing Graphics Output

E Click the Show the output path diagram button.

E In the Parameter Formats pane to the left of the drawing area, click Unstandardized 
estimates.

The following is the path diagram output of the unstandardized estimates, along with 
the test of the null hypothesis that age and vocabulary are uncorrelated:

The probability of accidentally getting a departure this large from the null hypothesis 
is 0.555. The null hypothesis would not be rejected at any conventional significance 
level.
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The usual t statistic for testing this null hypothesis is 0.59 ( ,  
two-sided). The probability level associated with the t statistic is exact. The probability 
level of 0.555 of the chi-square statistic is off, owing to the fact that it does not have an 
exact chi-square distribution in finite samples. Even so, the probability level of 0.555 
is not bad.

Here is an interesting question: If you use the probability level displayed by Amos 
to test the null hypothesis at either the 0.05 or 0.01 level, then what is the actual 
probability of rejecting a true null hypothesis? In the case of the present null 
hypothesis, this question has an answer, although the answer depends on the sample 
size. The second column in the next table shows, for several sample sizes, the real 
probability of a Type I error when using Amos to test the null hypothesis of zero 
correlation at the 0.05 level. The third column shows the real probability of a Type I 
error if you use a significance level of 0.01. The table shows that the bigger the sample 
size, the closer the true significance level is to what it is supposed to be. It’s too bad 
that such a table cannot be constructed for every hypothesis that Amos can be used to 
test. However, this much can be said about any such table: Moving from top to bottom, 
the numbers in the 0.05 column would approach 0.05, and the numbers in the 0.01 
column would approach 0.01. This is what is meant when it is said that hypothesis tests 
based on maximum likelihood theory are asymptotically correct.

The following table shows the actual probability of a Type I error when using Amos 
to test the hypothesis that two variables are uncorrelated:

Sample Size
Nominal Significance Level

0.05 0.01
3 0.250 0.122
4 0.150 0.056
5 0.115 0.038

10 0.073 0.018
20 0.060 0.013
30 0.056 0.012
40 0.055 0.012
50 0.054 0.011

100 0.052 0.011
150 0.051 0.010
200 0.051 0.010

>500 0.050 0.010

df 38= p 0.56=
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Modeling in VB.NET

Here is a program for performing the analysis of this example:

The AStructure method constrains the covariance, fixing it at a constant 0. The program 
does not refer explicitly to the variances of age and vocabulary. The default behavior 
of Amos is to estimate those variances without constraints. Amos treats the variance of 
every exogenous variable as a free parameter except for variances that are explicitly 
constrained by the program.
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4
Conventional Linear Regression

Introduction

This example demonstrates a conventional regression analysis, predicting a single 
observed variable as a linear combination of three other observed variables. It also 
introduces the concept of identifiability.

About the Data
Warren, White, and Fuller (1974) studied 98 managers of farm cooperatives. We will 
use the following four measurements:

A fifth measure, past training, was also reported, but we will not use it.
In this example, you will use the Excel worksheet Warren5v in the file 

UserGuide.xls, which is located in the Examples folder. If you performed a typical 
installation, the path is C:\Program Files\IBM\SPSS\Amos\19\Examples\ 
<language>.

Test Explanation

performance A 24-item test of performance related to “planning, organization, 
controlling, coordinating, and directing”

knowledge
A 26-item test of knowledge of “economic phases of 
management directed toward profit-making...and product 
knowledge”

value A 30-item test of “tendency to rationally evaluate means to an 
economic end”

satisfaction An 11-item test of “gratification obtained...from performing the 
managerial role”
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Here are the sample variances and covariances:

 

Warren5v also contains the sample means. Raw data are not available, but they are not 
needed by Amos for most analyses, as long as the sample moments (that is, means, 
variances, and covariances) are provided. In fact, only sample variances and 
covariances are required in this example. We will not need the sample means in 
Warren5v for the time being, and Amos will ignore them.

Analysis of the Data

Suppose you want to use scores on knowledge, value, and satisfaction to predict 
performance. More specifically, suppose you think that performance scores can be 
approximated by a linear combination of knowledge, value, and satisfaction. The 
prediction will not be perfect, however, and the model should thus include an error 
variable.

Here is the initial path diagram for this relationship:
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The single-headed arrows represent linear dependencies. For example, the arrow 
leading from knowledge to performance indicates that performance scores depend, in 
part, on knowledge. The variable error is enclosed in a circle because it is not directly 
observed. Error represents much more than random fluctuations in performance scores 
due to measurement error. Error also represents a composite of age, socioeconomic 
status, verbal ability, and anything else on which performance may depend but which 
was not measured in this study. This variable is essential because the path diagram is 
supposed to show all variables that affect performance scores. Without the circle, the 
path diagram would make the implausible claim that performance is an exact linear 
combination of knowledge, value, and satisfaction.

The double-headed arrows in the path diagram connect variables that may be 
correlated with each other. The absence of a double-headed arrow connecting error 
with any other variable indicates that error is assumed to be uncorrelated with every 
other predictor variable—a fundamental assumption in linear regression. Performance 
is also not connected to any other variable by a double-headed arrow, but this is for a 
different reason. Since performance depends on the other variables, it goes without 
saying that it might be correlated with them. 

Specifying the Model

Using what you learned in the first three examples, do the following:

E Start a new path diagram.

E Specify that the dataset to be analyzed is in the Excel worksheet Warren5v in the file 
UserGuide.xls.

E Draw four rectangles and label them knowledge, value, satisfaction, and performance.

E Draw an ellipse for the error variable.

E Draw single-headed arrows that point from the exogenous, or predictor, variables 
(knowledge, value, satisfaction, and error) to the endogenous, or response, variable 
(performance). 

Note: Endogenous variables have at least one single-headed path pointing toward them. 
Exogenous variables, in contrast, send out only single-headed paths but do not receive any.



70

Example 4

E Draw three double-headed arrows that connect the observed exogenous variables 
(knowledge, satisfaction, and value).

Your path diagram should look like this:

 

Identification

In this example, it is impossible to estimate the regression weight for the regression of 
performance on error, and, at the same time, estimate the variance of error. It is like 
having someone tell you, “I bought $5 worth of widgets,” and attempting to infer both 
the price of each widget and the number of widgets purchased. There is just not enough 
information.

You can solve this identification problem by fixing either the regression weight 
applied to error in predicting performance, or the variance of the error variable itself, 
at an arbitrary, nonzero value. Let’s fix the regression weight at 1. This will yield the 
same estimates as conventional linear regression.

Fixing Regression Weights

E Right-click the arrow that points from error to performance and choose Object Properties 
from the pop-up menu. 

E Click the Parameters tab.

E Type 1 in the Regression weight box.
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Setting a regression weight equal to 1 for every error variable can be tedious. 
Fortunately, Amos Graphics provides a default solution that works well in most cases.

E Click the Add a unique variable to an existing variable button.

E Click an endogenous variable.

Amos automatically attaches an error variable to it, complete with a fixed regression 
weight of 1. Clicking the endogenous variable repeatedly changes the position of the 
error variable.
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Viewing the Text Output

Here are the maximum likelihood estimates:

Amos does not display the path performance <— error because its value is fixed at the 
default value of 1. You may wonder how much the other estimates would be affected 
if a different constant had been chosen. It turns out that only the variance estimate for 
error is affected by such a change.

The following table shows the variance estimate that results from various choices for 
the performance <— error regression weight.

Suppose you fixed the path coefficient at 2 instead of 1. Then the variance estimate 
would be divided by a factor of 4. You can extrapolate the rule that multiplying the path 
coefficient by a fixed factor goes along with dividing the error variance by the square 

Fixed regression weight Estimated variance of error

0.5 0.050
0.707 0.025
1.0 0.0125
1.414 0.00625
2.0 0.00313
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of the same factor. Extending this, the product of the squared regression weight and the 
error variance is always a constant. This is what we mean when we say the regression 
weight (together with the error variance) is unidentified. If you assign a value to one 
of them, the other can be estimated, but they cannot both be estimated at the same time.

The identifiability problem just discussed arises from the fact that the variance of a 
variable, and any regression weights associated with it, depends on the units in which 
the variable is measured. Since error is an unobserved variable, there is no natural way 
to specify a measurement unit for it. Assigning an arbitrary value to a regression weight 
associated with error can be thought of as a way of indirectly choosing a unit of 
measurement for error. Every unobserved variable presents this identifiability 
problem, which must be resolved by imposing some constraint that determines its unit 
of measurement.

Changing the scale unit of the unobserved error variable does not change the overall 
model fit. In all the analyses, you get:

There are four sample variances and six sample covariances, for a total of 10 sample 
moments. There are three regression paths, four model variances, and three model 
covariances, for a total of 10 parameters that must be estimated. Hence, the model has 
zero degrees of freedom. Such a model is often called saturated or just-identified.

The standardized coefficient estimates are as follows:

Chi-square = 0.00
Degrees of freedom = 0
Probability level cannot be computed
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The standardized regression weights and the correlations are independent of the units 
in which all variables are measured; therefore, they are not affected by the choice of 
identification constraints.

Squared multiple correlations are also independent of units of measurement. Amos 
displays a squared multiple correlation for each endogenous variable. 

Note: The squared multiple correlation of a variable is the proportion of its variance that 
is accounted for by its predictors. In the present example, knowledge, value, and 
satisfaction account for 40% of the variance of performance.

Viewing Graphics Output

The following path diagram output shows unstandardized values:
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 Here is the standardized solution:

Viewing Additional Text Output

E In the tree diagram in the upper left pane of the Amos Output window, click Variable 
Summary.
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Endogenous variables are those that have single-headed arrows pointing to them; they 
depend on other variables. Exogenous variables are those that do not have single-
headed arrows pointing to them; they do not depend on other variables.

Inspecting the preceding list will help you catch the most common (and insidious) 
errors in an input file: typing errors. If you try to type performance twice but 
unintentionally misspell it as preformance one of those times, both versions will 
appear on the list.

E Now click Notes for Model in the upper left pane of the Amos Output window.

The following output indicates that there are no feedback loops in the path diagram:

Later you will see path diagrams where you can pick a variable and, by tracing along 
the single-headed arrows, follow a path that leads back to the same variable.

Note: Path diagrams that have feedback loops are called nonrecursive. Those that do 
not are called recursive. 

Notes for Group (Group number 1)
The model is recursive.
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Modeling in VB.NET

The model in this example consists of a single regression equation. Each single-headed 
arrow in the path diagram represents a regression weight. Here is a program for 
estimating those regression weights:

 

The four lines that come after Sem.BeginGroup correspond to the single-headed arrows 
in the Amos Graphics path diagram. The (1) in the last AStructure line fixes the error 
regression weight at a constant 1.

Assumptions about Correlations among Exogenous Variables

When executing a program, Amos makes assumptions about the correlations among 
exogenous variables that are not made in Amos Graphics. These assumptions simplify 
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the specification of many models, especially models that have parameters. The 
differences between specifying a model in Amos Graphics and specifying one 
programmatically are as follows:

Amos Graphics is entirely WYSIWYG (What You See Is What You Get). If you 
draw a two-headed arrow (without constraints) between two exogenous variables, 
Amos Graphics will estimate their covariance. If two exogenous variables are not 
connected by a double-headed arrow, Amos Graphics will assume that the 
variables are uncorrelated.

The default assumptions in an Amos program are:

Unique variables (unobserved, exogenous variables that affect only one other 
variable) are assumed to be uncorrelated with each other and with all other 
exogenous variables.

Exogenous variables other than unique variables are assumed to be correlated 
among themselves.

In Amos programs, these defaults reflect standard assumptions of conventional linear 
regression analysis. Thus, in this example, the program assumes that the predictors, 
knowledge, value, and satisfaction, are correlated and that error is uncorrelated with 
the predictors.

Equation Format for the AStructure Method

The AStructure method permits model specification in equation format. For instance, 
the single Sem.AStructure statement in the following program describes the same 
model as the program on p. 77 but in a single line. This program is saved under the 
name Ex04-eq.vb in the Examples directory.
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Note that in the AStructure line above, each predictor variable (on the right side of the 
equation) is associated with a regression weight to be estimated. We could make these 
regression weights explicit through the use of empty parentheses as follows:

Sem.AStructure("performance = ()knowledge + ()value + ()satisfaction + error(1)")

The empty parentheses are optional. By default, Amos will automatically estimate a 
regression weight for each predictor.
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5
Unobserved Variables

Introduction

This example demonstrates a regression analysis with unobserved variables.

About the Data

The variables in the previous example were surely unreliable to some degree. The fact 
that the reliability of performance is unknown presents a minor problem when it 
comes to interpreting the fact that the predictors account for only 39.9% of the 
variance of performance. If the test were extremely unreliable, that fact in itself would 
explain why the performance score could not be predicted accurately. Unreliability of 
the predictors, on the other hand, presents a more serious problem because it can lead 
to biased estimates of regression weights.

The present example, based on Rock, et al. (1977), will assess the reliabilities of 
the four tests included in the previous analysis. It will also obtain estimates of 
regression weights for perfectly reliable, hypothetical versions of the four tests. Rock, 
et al. re-examined the data of Warren, White, and Fuller (1974) that were discussed 
in the previous example. This time, each test was randomly split into two halves, and 
each half was scored separately.
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Here is a list of the input variables:

For this example, we will use a Lotus data file, Warren9v.wk1, to obtain the sample 
variances and covariances of these subtests. The sample means that appear in the file 
will not be used in this example. Statistics on formal education (past_training) are 
present in the file, but they also will not enter into the present analysis. The following 
is a portion of the dataset:

Variable name Description

1performance 12-item subtest of Role Performance
2performance 12-item subtest of Role Performance
1knowledge 13-item subtest of Knowledge
2knowledge 13-item subtest of Knowledge
1value 15-item subtest of Value Orientation
2value 15-item subtest of Value Orientation
1satisfaction 5-item subtest of Role Satisfaction
2satisfaction 6-item subtest of Role Satisfaction
past_training degree of formal education











477

Censored Data

known more precisely than it is. Of course, wherever the data provide an exact numeric 
value, as in the case of Patient 24 who is known to have survived for 218 days, that 
exact numeric value is used.

Recoding the Data

The data file needs to be recoded before Amos reads it. The next figure shows a portion 
of the dataset after recoding. (This complete dataset is in the file transplant-b.sav.)

Every uncensored observation appears in the new data file just the way it did in the 
original data file. Censored values, however, are coded differently. For example, 
Patient 25’s survival time, which is known only to be greater than 1,799, is coded as 
> 1799 in the new data file. (Spaces in a string like > 1799 are optional.) The square root 
of survival time is known to be greater than 42.415, so the timesqr column of the data 
file contains > 42.415 for Patient 25. For data file formats (like SPSS Statistics) that 
make a distinction between numeric and string variables, time and timesqr need to be 
coded as string variables.

Analyzing the Data

To specify the data file in Amos Graphics:

E From the menus, choose File → Data Files.
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E Then in the Data Files dialog box, click the File Name button.

E Select the data file transplant-b.sav. 

E Select Allow non-numeric data (a check mark appears next to it).

Recoding the data as shown above and selecting Allow non-numeric data are the only 
extra steps that are required for analyzing censored data. In all other respects, fitting a 
model with censored data and interpreting the results is exactly the same as if the data 
were purely numeric.

Performing a Regression Analysis

Let’s try predicting timesqr using age and year of acceptance (acceptyr) as predictors. 
Begin by drawing the following path diagram:

timesqr

age 0,

e
1

acceptyr
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To fit the model:

E Click  on the toolbar.

or

E From the menus, choose Analyze → Bayesian Estimation.

Note: The  button is disabled because, with non-numeric data, you can perform only 
Bayesian estimation.

After the Bayesian SEM window opens, wait until the unhappy face  changes into 
a happy face . The table of estimates in the Bayesian SEM window should look 
something like this:

(Only a portion of the table is shown in the figure.) The Mean column contains point 
estimates for the parameters. The regression weight for using acceptyr to predict 
timesqr is 1.45, so that each time the calendar advances by one year, you predict an 
increase of 1.45 in the square root of survival time. This suggests that the transplant 
program may have been improving over the period covered by the study. The 
regression weight for using age to predict timesqr is –0.29, so for every year older a 
patient is when admitted into the transplant program, you expect a decrease of 0.29 in 
the square root of survival time. The regression weight estimate of –0.29 is actually the 
mean of the posterior distribution of the regression weight. 

E To see the entire posterior distribution, right-click the row that contains the –0.29 
estimate and choose Show Posterior from the pop-up menu.
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The Posterior dialog box opens, displaying the posterior distribution of the regression 
weight.

The posterior distribution of the regression weight is indeed centered around –0.29. 
The distribution lies almost entirely between –0.75 and 0.25, so it is practically 
guaranteed that the regression weight lies in that range. Most of the distribution lies 
between –0.5 and 0, so we are pretty sure that the regression weight lies between –0.5 
and 0.
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Posterior Predictive Distributions

Recall that the dataset contains some censored values like Patient 25’s survival time. 
All we really know about Patient 25’s survival time is that it is longer than 1,799 days 
or, equivalently, that the square root of survival time exceeds 42.415. Even though we 
do not know the amount by which this patient’s timesqr exceeds 42.415, we can ask 
for its posterior distribution. Taking into account the fact that timesqr exceeds 42.415, 
assuming that the model is correct, and taking the patient’s age and acceptyr into 
account, what can be said about Patient 25’s survival time? To find out:

E Click the Posterior Predictive button .

or

E From the menus, choose View → Posterior Predictive.

The Posterior Predictive Distributions window shows a table with a row for every 
person and a column for every observed variable in the model. Looking in the 25th row, 
we see Patient 25’s age and acceptyr scores. For Patient 25’s timesqr, all we see is the 
symbol <<, which indicates that the data provide an inequality constraint on the timesqr 
score and not an actual numeric value.

To see the posterior distribution of Patient 25’s timesqr:

E Click <<. The posterior distribution appears in the Posterior window.
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The posterior distribution for Patient 25’s timesqr lies entirely to the right of 42.415. 
Of course, we knew from the data alone that timesqr exceeds 42.415, but now we also 
know that there is practically no chance that Patient 25’s timesqr exceeds 70. For that 
matter, there is only a slim chance that timesqr exceeds even 55.

To see a posterior predictive distribution that looks very different from Patient 25’s:

E Click the << symbol in the 100th row of the Posterior Predictive Distributions table.
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Patient 100 was still alive when last observed on the 38th day after acceptance into the 
program, so that his timesqr is known to exceed 6.164. The posterior distribution of 
that patient’s timesqr shows that it is practically guaranteed to be between 6.164 and 
70, and almost certain to be between, 6.164 and 50. The mean is 27.36, providing a 
point estimate of timesqr if one is needed. Squaring 27.36 gives 748, an estimate of 
Patient 100’s survival time in days.
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Imputation

You can use this model to impute values for the censored values.

E Close the Bayesian SEM window if it is open.

E From the Amos Graphics menu, choose Analyze → Data Imputation.

Notice that Regression imputation and Stochastic regression imputation are disabled. 
When you have non-numeric data such as censored data, Bayesian imputation is the only 
choice.

We will accept the options shown in the preceding figure, creating 10 completed 
datasets and saving all 10 in a single SPSS Statistics data file called transplant-
b_C.sav. To start the imputation:

E Click the Impute button.

The Bayesian SEM window opens along with the Data Imputation dialog box.
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E Wait until the Data Imputation dialog box displays a happy face  to indicate that 
each of the 10 completed datasets is effectively uncorrelated with the others.

Note: After you see a happy face but before you click OK, you may optionally choose to 
right-click a parameter in the Bayesian SEM window and choose Show Posterior from 
the pop-up menu. This will allow you to examine the Trace and Autocorrelation plots.

E Click OK in the Data Imputation dialog box.

The Summary window shows a list of the completed data files that were created. In this 
case, only one completed data file was created.
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E Double-click the file name to display the contents of the single completed data file, 
which contains 10 completed datasets. 

The file contains 1,030 cases because each of the 10 completed datasets contains 103 
cases. The first 103 rows of the new data file contain the first completed dataset. The 
Imputation_ variable is equal to 1 for each row in the first completed dataset, and the 
CaseNo variable runs from 1 through 103.
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The first row of the completed data file contains a timesqr value of 7. Because that was 
not a censored value, 7 is not an imputed value. It is just an ordinary numeric value that 
was present in the original data file. On the other hand, Patient 25’s timesqr was 
censored, so that patient has an imputed timesqr (in this case, 49.66.) The value of 
49.66 is a value drawn randomly from the posterior predictive distribution in the figure 
on p. 482.



488

Example 32

Normally, the next step would be to use the 10 completed datasets in transplant-
b_C.sav as input to some other program that cannot accept censored data. You would 
use that other program to perform 10 separate analyses, using each one of the 10 
completed datasets in turn. Then you would do further computations to combine the 
results of those 10 separate analyses into a single set of results, as was done in Example 
31. Those steps will not be carried out here.

General Inequality Constraints on Data Values

This example employed only inequality constraints like > 1799. Here are some other 
examples of string values that can be used in a data file to place inequality constraints 
on the value of an underlying numeric variable:

The string value < 5 means that the underlying numeric value is less than 5.

The string value 4<<5 means that the underlying numeric value is between 4 and 5.
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Ordered-Categorical Data

Introduction

This example shows how to fit a factor analysis model to ordered-categorical data. It 
also shows how to find the posterior predictive distribution for the numeric variable 
that underlies a categorical response and how to impute a numeric value for a 
categorical response.

About the Data

This example uses data on attitudes toward environment issues obtained from a 
questionnaire administered to 1,017 respondents in the Netherlands. The data come 
from the European Values Study Group (see the bibliography for a citation). The data 
file environment-nl-string.sav contains responses to six questionnaire items with 
categorical responses strongly disagree (SD), disagree (D), agree (A), and strongly 
agree (SA).
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One way to analyze these data is to assign numbers to the four categorical responses; 
for example, using the assignment 1 = SD, 2 = D, 3 = A, 4 = SA. If you assign numbers 
to categories in that way, you get the dataset in environment-nl-numeric.sav.

In an Amos analysis, it is not necessary to assign numbers to categories in the way just 
shown. It is possible to use only the ordinal properties of the four categorical responses. 
If you want to use only the ordinal properties of the data, you can use either dataset, 
environment-nl-string.sav or environment-nl-numeric.sav.
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It may be slightly easier to use environment-nl-numeric.sav because Amos will 
assume by default that the numbered categories go in the order 1, 2, 3, 4, with 1 being 
the lowest category. That happens to be the correct order. With environment-nl-
string.sav, by contrast, Amos will assume by default that the categories are arranged 
alphabetically in the order A, D, SA, SD, with A being the lowest category. That is the 
wrong order, so the default ordering of the categories by Amos has to be overridden.

The data file environment-nl-string.sav will be used for this example because then 
it will be clear that only the ordinal properties of the data are employed, and also you 
can see how to specify the correct ordering of the categories.

Specifying the Data File

E From the Amos Graphics menus , choose File → Data Files. 

E In the Data Files window, click the File Name button.

E Select the data file environment-nl-string.sav. 

E Select Allow non-numeric data (a check mark appears next to it).

E Click OK.
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Recoding the Data within Amos

The ordinal properties of the data cannot be inferred from the data file alone. To give 
Amos the additional information it needs so that it can interpret the data values SD, D, 
A, and SA:

E From the Amos Graphics menus, choose Tools → Data Recode. 

E Select item1 in the list of variables in the upper-left corner of the Data Recode window.

This displays a frequency distribution of the responses to item1 at the bottom of the 
window.
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In the box labeled Recoding rule, the notation No recoding means that Amos will read 
the responses to item1 as is. In other words, it will read either SD, D, A, SA, or an empty 
string. We can’t leave things that way because Amos doesn’t know what to do with SD, 
D, and so on.

E Click No recoding and select Ordered-categorical from the drop-down list.
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The frequency table at the bottom of the window now has a New Value column that 
shows how the item1 values in the data file will be recoded before Amos reads the data. 
The first row of the frequency table shows that empty strings in the original data file 
will be treated as missing values. The second row shows that the A response will be 
translated into the string <0.0783345405060296. Amos will interpret this to mean that 
there is a continuous numeric variable that underlies responses to item1, and that a 
person who gives the A response has a score that is less than 0.0783345405060296 on 
that underlying variable. Similarly, the third row shows that the D response will be 
translated into the string 0.0783345405060296<<0.442569286522029 and interpreted 
by Amos to mean that the score on the underlying numeric variable is between 
0.0783345405060296 and 0.442569286522029. The numbers, 0.0783345405060296, 
0.442569286522029, and so on, are derived from the frequencies in the Frequency 
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column, based on the assumption that scores on the underlying numeric variable are 
normally distributed with a mean of 0 and a standard deviation of 1.

The ordering of the categories in the Original Value column needs to be changed. To 
change the ordering:

E Click the Details button. The Ordered-Categorical Details dialog box opens.

The Ordered categories list box shows four response categories arranged in the order 
A, D, SA, SD, and separated from each other by dashed lines, <---->. The dashed 
lines represent three boundaries that divide the real numbers into four intervals, with 
the four intervals being associated with the four categorical responses. The assumption 
is made that a person who scores below the lowest boundary on some unobserved 
numeric variable gives the A response. A person who scores between the lowest 
boundary and the middle boundary gives the D response. A person who scores between 
the middle boundary and the highest boundary gives the SA response. Finally, a person 
who scores above the highest boundary gives the SD response.

The program is correct about there being four categories (intervals) and three 
boundaries, but it has the ordering of the categories wrong. The program arbitrarily 
alphabetized the categories. We need to keep the four categories and the three 
boundaries but rearrange them. We want SD to fall in the lowest interval (below the 
lowest boundary), and so on. 
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You can rearrange the categories and the boundaries. To do this:

E Drag and drop with the mouse.

or

E Select a category or boundary with the mouse and then click the Up or Down button.

After putting the categories and boundaries in the correct order, the Ordered-
Categorical Details dialog box looks like this:

The Unordered categories list box contains a list of values that Amos will treat as 
missing. At the moment, the list contains one entry, [empty string], so that Amos will 
treat an empty string as a missing value. If a response coded as an empty string was 
actually a response that could be meaningfully compared to SD, D, A, and SA, then you 
would select [empty string] in the Unordered categories list box and click the Down 
button to move [empty string] into the Ordered categories list box. 

Similarly, if a response in the Ordered categories list box, for example SD, was not 
comparable to the other responses, you would select it with the mouse and click the Up 
button to move it into the Unordered categories list box. Then SD would be treated as 
a missing value.
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Note: You can’t drag and drop between the Ordered categories list box and the 
Unordered categories list box. You have to use the Up and Down buttons to move a 
category from one box to the other.

We could stop here and close the Ordered-Categorical Details dialog box because we 
have the right number of boundaries and categories and we have the categories going 
in the right order. However, we will make a further change based on a suggestion by 
Croon (2002), who also worked with this dataset and concluded that the SD category 
occurred so seldom that it should be combined with the D category. To merge those 
two categories into a single category:

E Select the boundary between the two categories you want to merge.

E Click the Remove Boundary button. The Ordered categories list now looks like this:

Now the SD response and the D response are indistinguishable. Either response means 
that the person who gave the response has a score that lies in the lowest interval on the 
underlying numeric variable.

There remains the question of the values of the two boundaries that separate the 
three intervals. If you do not specify values for the boundaries, Amos will estimate the 
boundaries by assuming that scores on the underlying numeric variable are normally 
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distributed with a mean of 0 and a standard deviation of 1. Alternatively, you can 
assign a value to a boundary instead of letting Amos estimate it. To assign a value:

E Select the boundary with the mouse.

E Type a numeric value in the text box.

The following figure shows the result of assigning values 0 and 1 to the two 
boundaries.

Although it may not be obvious, it is permissible to assign 0 and 1, or any pair of 
numbers, to the two boundaries, as long as the higher boundary is assigned a larger 
value than the lower one. No matter how many boundaries there are (as long as there 
are at least two), assigning values to two of the boundaries amounts to choosing a zero 
point and a unit of measurement for the underlying numeric variable. The scaling of 
the underlying numeric variable is discussed further in the Help file under the topic 
“Choosing boundaries when there are three categories.”

E Click OK to close the Ordered-Categorical Details dialog box.
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The changes that were just made to the categories and the interval boundaries are now 
reflected in the frequency table at the bottom of the Data Recode window.

The frequency table shows how the values that appear in the data file will be recoded 
before Amos reads them. Reading the frequency table from top to bottom:

An empty string will be treated as a missing value.

The strings SD and D will be recoded as <0, meaning that the underlying numeric 
score is less than 0.

A will be recoded as 0<<1, meaning that the underlying numeric score is between 
0 and 1.

SA will be recoded as >1, meaning that the underlying numeric score is greater
than 1.
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That takes care of item1. What was just done for item1 has to be repeated for each of 
the five remaining observed variables. After specifying the recoding for all six 
observed variables, you can view the original dataset along with the recoded variables. 
To do this:

E Click the View Data button.

The table on the left shows the contents of the original data file before recoding. The 
table on the right shows the recoded variables after recoding. When Amos performs an 
analysis, it reads the recoded values, not the original values.

Note: You can create a raw data file in which the data recoding has already been 
performed. In other words, you can create a raw data file that contains the inequalities 
on the right-hand side of the figure above. In that case, you wouldn’t need to use the 
Data Recode window in Amos. Indeed, that approach was used in Chapter 32.

E Finally, close the Data Recode window before specifying the model.

Specifying the Model

After you have specified the rules for data recoding as shown above, the analysis 
proceeds just like any Bayesian analysis. For this example, a factor analysis model will 
be fitted to the six questionnaire items in the environment dataset. The first three items 
were designed to be measures of willingness to spend money to take care of the 
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environment. The other three items were designed to be measures of awareness of 
environmental issues. This design of the questionnaire is reflected in the following 
factor analysis model, which is saved in the file Ex33-a.amw.

The path diagram is drawn exactly as it would be drawn for numeric data. This is one 
of the good things about having at least three categories for each ordered-categorical 
variable: You can specify a model in the way that you are used to, just as though all the 
variables were numeric, and the model will work for any combination of numeric and 
ordered-categorical variables. If variables are dichotomous, you will need to impose 
additional parameter constraints in order to make the model identified. This issue is 
discussed further in the online Help under the topic “Parameter identification with 
dichotomous variables.”

Fitting the Model

E Click  on the toolbar.

or

E From the menus, choose Analyze → Bayesian Estimation.

Note: The  button is disabled because, with non-numeric data, you can perform only 
Bayesian estimation.
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After the Bayesian SEM window opens, wait until the unhappy face changes into a 
happy face. The Bayesian SEM window should then look something like this:

(The figure above shows some, but not all, of the parameter estimates.) The Mean 
column provides a point estimate for each parameter. For example, the regression 
weight for using WILLING to predict item1 is estimated to be 0.59. The skewness 
(0.09) and kurtosis (–0.01) of the posterior distribution are close to 0, which is 
compatible with the posterior distribution being nearly normal. The standard deviation 
(S.D.) is 0.03, so there is about a 67% chance that the regression weight is within 0.03 
of 0.59. Doubling the standard deviation gives 0.06, so there is about a 95% chance 
that the regression weight is within 0.06 of 0.59. 

To view the posterior distribution of the regression weight:

E Right-click its row and choose Show Posterior from the pop-up menu.
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The Posterior window displays the posterior distribution. The appearance of the 
distribution confirms what was concluded above from the mean, standard deviation, 
skewness, and kurtosis of the distribution. The shape of the distribution is nearly 
normal, and it looks like roughly 95% of the area lies between 0.53 and 0.65 (that is, 
within 0.06 of 0.59). 
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MCMC Diagnostics

If you know how to interpret the diagnostic output from MCMC algorithms (for 
example, see Gelman, et al, 2004), you might want to view the Trace plot and the 
Autocorrelation plot.
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The First and last plot provides another diagnostic. It shows two estimates of the 
posterior distribution (two superimposed plots), one estimate from the first third of the 
MCMC sample and another estimate from the last third of the MCMC sample.
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Posterior Predictive Distributions

When you think of estimation, you normally think of estimating model parameters or 
some function of the model parameters such as a standardized regression weight or an 
indirect effect. However, there are other unknown quantities in the present analysis. 
Each entry in the data table on p. 490 represents a numeric value that is either unknown 
or partially known. For example, Person 1 did not respond to item2, so we can only 
guess at (estimate) that person’s score on the underlying numeric variable. On the other 
hand, it seems like we ought to be able to make a fairly educated guess about the 
underlying numeric value, considering that we know how the person responded to the 
other items, and that we can also make use of the assumption that the model is correct.
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We are in an even better position to guess at Person 1’s score on the numeric 
variable that underlies item1 because Person 1 gave a response to item1. This person’s 
response places his or her score in the middle interval, between the two boundaries. 
Since the two boundaries were arbitrarily fixed at 0 and 1, we know that the score is 
somewhere between 0 and 1, but it seems like we should be able to say more than that 
by using the person’s responses on the other variables along with the assumption that 
the model is correct.

In Bayesian estimation, all unknown quantities are treated in the same way. Just as 
unknown parameter values are estimated by giving their posterior distribution, so are 
unknown data values. A posterior distribution for an unknown data value is called a 
posterior predictive distribution, but it is interpreted just like any posterior 
distribution. To view posterior predictive distributions for unknown data values:

E Click the Posterior Predictive button .

or

E From the menus, choose View → Posterior Predictive.

The Posterior Predictive Distributions window appears.
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The Posterior Predictive Distributions window contains a table with a row for every 
person and a column for every observed variable in the model. An asterisk (*) indicates 
a missing value, while << indicates a response that places inequality constraints on the 
underlying numeric variable. To display the posterior distribution for an item:

E Click on the table entry in the upper-left corner (Person 1’s response to item1).

The Posterior window opens, displaying the posterior distribution of Person 1’s 
underlying numeric score. At first, the posterior distribution looks jagged and random.
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That is because the program is building up an estimate of the posterior distribution as 
MCMC sampling proceeds. The longer you wait, the better the estimate of the 
posterior distribution will be. After a while, the estimate of the posterior distribution 
stabilizes and looks something like this:

The posterior distribution shows that Person 1’s score on the numeric variable that 
underlies his or her response to item1 is between 0 and 1 (which we knew already), and 
that the score is more likely to be close to 1 than close to 0.
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E Next, click the table entry in the first column of the 22nd row to estimate Person 22’s 
score on the numeric variable that underlies his or her response to item1. 

After you wait a while to get a good estimate of the posterior distribution, you see this:

Both Person 1 and Person 22 gave the agree response to item1, so both people have 
scores between 0 and 1 on the underlying numeric variable; however, their posterior 
distributions are very different

For another example of a posterior predictive distribution, select a missing value 
like Person 1’s response to item2. After allowing MCMC sampling to proceed long 
enough to get a good estimate of the posterior distribution, it looks like this:



511

Ordered-Categorical Data

The mean of the posterior distribution (0.52) can be taken as an estimate of Person 1’s 
score on the underlying variable if a point estimate is required. Looking at the plot of 
the posterior distribution, we can be nearly 100% sure that the score is between –1 and 
2. The score is probably between 0 and 1 because most of the area under the posterior 
distribution lies between 0 and 1.

Posterior Predictive Distributions for Latent Variables

Suppose you want to estimate Person 1’s score on the WILLING factor. Amos can 
estimate posterior predictive distributions for unknown scores only for observed 
variables. It cannot estimate a posterior predictive distribution of a score on a latent 
variable. However, there is a trick that you can use to estimate the posterior predictive 
distribution of a score on WILLING. You can change WILLING to an observed 
variable, treating it not as a latent variable but as an observed variable that has a 
missing value for every case. That requires two changes – a change to the path diagram 
and a change to the data. 

In the path diagram, the WILLING ellipse has to be changed into a rectangle. To 
accomplish this:

E Right-click the WILLING ellipse and choose Toggle Observed/Unobserved from the pop-
up menu.

E Click the WILLING ellipse.

The WILLING ellipse changes to a rectangle so that the path diagram looks like this:



512

Example 33

That takes care of the path diagram. It is also necessary to make a change to the data 
because if WILLING is an observed variable, then there has to be a WILLING column 
in the data file. You can directly modify the data file. Since this is a data file in SPSS 
Statistics format, you would use SPSS Statistics to add a WILLING variable to the data 
file, making sure that all the scores on WILLING are missing. 

To avoid changing the original data file:

E Right-click the WILLING variable in the path diagram

E Choose Data Recode from the pop-up menu to open the Data Recode window.

E In the Data Recode window, click Create Variable. A new variable with the default 
name V1, appears in the New and recoded variables list box.
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E Change V1 to WILLING. (If necessary, click the Rename Variable button.)
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E You can optionally view the recoded dataset that includes the new WILLING variable 
by clicking the View Data button.
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The table on the left shows the original dataset. The table on the right shows the 
recoded dataset as read by Amos. It includes item1 through item6 after recoding, and 
also the new WILLING variable.

E Close the Data Recode window.

E Start the Bayesian analysis by clicking  on the Amos Graphics toolbar. 

E In the Bayesian SEM window, wait until the unhappy face  changes into a happy 
face  and then click the Posterior Predictive button .

E Click the entry in the upper-right corner of the table to display the posterior distribution 
of Person 1’s score on the WILLING factor.
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Imputation

Data imputation works the same way for ordered-categorical data as it does for 
numeric data. With ordered-categorical data, you can impute numeric values for 
missing values, for scores on latent variables, and for scores on the unobserved 
numeric variables that underlie observed ordered-categorical measurements.

You need a model in order to perform imputation. You could use the factor analysis 
model that was used earlier. There are several advantages and one disadvantage to 
using the factor analysis model for imputation. One advantage is that, if the model is 
correct, you can impute values for the factors. That is, you can create a new data set in 
which WILLING and AWARE are observed variables. The other advantage is that, if 
the factor analysis model is correct, it can be expected to give more accurate 
imputations for item1 through item6 than would be obtained from a less restrictive 
model. The disadvantage of using the factor analysis model is that it may be wrong. To 
be on the safe side, the present example will use the model that has the biggest chance 
of being correct, the saturated model shown in the following figure. (See the file
Ex33-c.amw.)
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After drawing the path diagram for the saturated model, you can begin the imputation.

E From the Amos Graphics menu, choose Analyze → Data Imputation.

item1

item2

item3

item6

item4

item5
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In the Amos Data Imputation window, notice that Regression imputation and Stochastic 
regression imputation are disabled. When you have non-numeric data, Bayesian 

imputation is the only choice.
We will accept the options shown in the preceding figure, creating 10 completed 

datasets and saving all 10 in a single SPSS Statistics data file called environment-nl-
string_C.sav. To start the imputation:

E Click the Impute button. 

The Bayesian SEM window opens along with the Data Imputation dialog box.

E Wait until the Data Imputation dialog box displays a happy face  to indicate that 
each of the 10 completed data sets is effectively uncorrelated with the others.

Note: After you see a happy face but before you click OK, you may optionally right-
click a parameter in the Bayesian SEM window and choose Show Posterior from the 
pop-up menu. This will allow you to examine the Trace and Autocorrelation plots.
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E Click OK in the Data Imputation dialog box.

The Summary window shows a list of the completed data files that were created. In this 
case, only one completed data file was created.

E Double-click the file name in the Summary window to display the contents of the 
single completed data file, which contains 10 completed data sets.

The file contains 10,170 cases because each of the 10 completed data sets contains 
1,017 cases. The first 1,017 rows of the new data file contain the first completed data 
set. The Imputation_ variable is equal to 1 for each row in the first completed data set, 
and the CaseNo variable runs from 1 through 1,017 before starting over again at 1.
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Normally, the next step would be to use the 10 completed data sets in environment-nl-
string_C.sav as input to some other program that requires numeric (not ordered-
categorical) data. You would use that other program to perform 10 separate analyses 
using each one of the 10 completed data sets in turn. Then, you would do further 
computations to combine the results of those 10 separate analyses into a single set of 
results, as was done in Example 31. Those steps will not be carried out here.
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34
Mixture Modeling with Training Data

Introduction

Mixture modeling is appropriate when you have a model that is incorrect for an entire 
population, but where the population can be divided into subgroups in such a way that 
the model is correct in each subgroup.

Mixture modeling is discussed in the context of structural equation modeling by 
Arminger, Stein, and Wittenberg (1999), Hoshino (2001), Lee (2007, Chapter 11), 
Loken (2004), Vermunt and Magidson (2005), and Zhu and Lee (2001), among 
others.

The present example demonstrates mixture modeling for the situation in which 
some cases have already been assigned to groups while other cases have not. It is up 
to Amos to learn from the cases that are already classified and to classify the others.

We begin mixture modeling with an example in which some cases have already 
been classified because setting up such an analysis is almost identical to setting up an 
ordinary multiple-group analysis such as in Examples 10, 11, and 12.

It is possible to perform mixture modeling when no cases have been classified in 
advance so that the program must classify every case. Example 35 demonstrates this 
type of analysis.

About the Data

The data for this example were collected by Anderson (1935) and used by Fisher 
(1936) to demonstrate discriminant analysis. The original data are in the file iris.sav, 
of which a portion is shown here:
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The dataset contains four measurements on flowers from 150 different plants. The first 
50 flowers were irises of the species setosa. The next 50 were irises of the species 
versicolor. The last 50 were of the species virginica.

A scatterplot of two of the numeric measurements, PetalLength and PetalWidth, 
suggests that those two measurements alone will be useful in classifying the flowers 
according to species.



523

Mixture Modeling with Training Data

The setosa flowers are all by themselves in the lower left corner of the scatterplot. It 
should therefore be easy for Amos to use PetalLength and PetalWidth to distinguish 
the setosa flowers from the others. On the other hand, there is some overlap of 
versicolor and virginica, so we should expect that sometimes it will be hard to tell 
whether a flower is versicolor or virginica purely on the basis of PetalLength and 
PetalWidth.

This example will not use the iris.sav dataset, which gives the species of every 
flower. Instead, the example will use the iris3.sav dataset, which gives the species for 
only a few flowers. The following figure shows a portion of the iris3.sav dataset.
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Species information is available for 10 of the setosa flowers, 10 of the versicolor 
flowers, and 10 of the virginica flowers. Species is unknown for the remaining 120 
flowers. When Amos analyzes these data, it will have 10 examples of each kind of 
flower to assist in classifying the rest of the flowers.

Performing the Analysis

E From the menus, choose File → New to start a new path diagram.

E From the menus, choose Analyze → Manage Groups.

E In the Manage Groups dialog box, change the name in the Group Name text box from 
Group number 1 to PossiblySetosa.
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E Click New to create a second group.

E Change the name in the Group Name text box from Group number 2 to 
PossiblyVersicolor.

E Click New to create a third group.

E Change the name in the Group Name text box from Group number 3 to 
PossiblyVirginica.

E Click Close.
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Specifying the Data File

E From the menus, choose File → Data Files.

E Click PossiblySetosa to select that row.

E Click File Name, select the iris3.sav file that is in the Amos Examples directory, and 
click Open.

E Click Grouping Variable and double-click Species in the Choose a Grouping Variable 
dialog box. This tells the program that the Species variable will be used for classifying 
flowers.
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E In the Data Files dialog box, click Group Value and then double-click setosa in the 
Choose Value for Group dialog box.
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The Data Files dialog box should now look like this:
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E Repeat the preceding steps for the PossiblyVersicolor group, but this time double-click 
versicolor in the Choose Value for Group dialog box.

E Repeat the preceding steps once more for the PossiblyVirginica group, but this time 
double-click virginica in the Choose Value for Group dialog box. The Data Files dialog 
box will end up looking like this:

So far, the analysis has been set up exactly like an ordinary three-group analysis in 
which the species of every flower is known. The next step is unique to mixture 
modeling. 

E Select Assign cases to groups (a check mark will appear next to it). The check mark tells 
Amos to assign a case to a group whenever the dataset does not specify which group 
that case belongs to.
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E Click OK to close the Data Files dialog box.

Specifying the Model

We will use a saturated model for the variables PetalLength and PetalWidth. The 
scatterplot that was shown earlier suggests that these two variables will allow the 
program to do a good job of classifying the flowers according to species.

Note that you are not limited to saturated models when doing mixture modeling. 
You can use a factor analysis model or a regression model or any other kind of model. 
See Example 36 for a demonstration of mixture modeling with a regression model.

E Draw the following path diagram. (This path diagram is saved as Ex34-a.amw.)
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E From the menus, choose View → Analysis Properties.

E Select Estimate means and intercepts (a check mark will appear next to it). 
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Fitting the Model

E Click  on the toolbar.

or

E From the menus, choose Analyze → Bayesian Estimation.

Note: The  button is disabled because, in mixture modeling, you can perform only 
Bayesian estimation.
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After the Bayesian SEM window opens, wait until the unhappy face  changes into 
a happy face . The table of estimates in the Bayesian SEM window should look 
something like this:

The Bayesian SEM window displays all of the parameter estimates that you would get 
in an ordinary three-group analysis. The table displays the results for one group at a 
time. You can switch from one group to another by clicking the tabs at the top of the 
table. In this example, the model parameters include only means, variances, and 
covariances. In a more complicated model, there would also be estimates of regression 
weights and intercepts.

In a mixture modeling analysis, you also get an estimate of the proportion of the 
population that lies in each group. The preceding figure shows that the proportion of 
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setosa flowers in the population is estimated to be 0.333. (It should be pointed out that 
it was by design that the sample contained equal numbers of setosa, versicolor, and 
virginica flowers. It is therefore not meaningful in this example to draw inferences 
about population proportions from the sample. Nevertheless, we will treat species here 
as a random variable in order to demonstrate how such inferences can be made.)

To view the posterior distribution of a population proportion, right-click the row that 
contains the proportion and choose Show Posterior from the popup menu.
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The Posterior window shows that the proportion of flowers that belong to the setosa 
species is almost certainly between 0.25 and 0.45. It looks like there is about a 50–50 
chance that the proportion is somewhere between 0.3 and 0.35.

Classifying Individual Cases

To obtain probabilities of group membership for each individual flower:

E Click the Posterior Predictive button .

or

E From the menus, choose View → Posterior Predictive.
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For each flower, the Posterior Predictive Distributions window shows the probability 
that that flower is setosa, versicolor, or virginica.

For the first 50 flowers (the ones that actually are setosa), the probability of 
membership in the setosa group is nearly 1. We expected that result because the setosa 
flowers were clearly separated from flowers of other species in the scatterplot shown 
earlier.

Most of the versicolor flowers (starting with case number 51) were also correctly 
classified. For example, flower number 51 has posterior probability 0.95 of being 
versicolor. However, classification errors do occur. Case number 71, for example, is 
misclassified. It is a versicolor flower, but it is estimated to have a 0.74 probability of 
being virginica.
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Latent Structure Analysis

It was mentioned earlier that you are not limited to saturated models when doing 
mixture modeling. You can use a factor analysis model, a regression model, or any 
model at all. You may want to become familiar with an important variation of the 
saturated model. Latent structure analysis (Lazarsfeld and Henry, 1968) is a variation 
of mixture modeling in which the measured variables are required to be independent 
within each group. When the measured variables are multivariate normal, they are 
required to be uncorrelated.

E To require that the measured variables be uncorrelated, delete the double-headed arrow 
in the path diagram of the saturated model. (This path diagram is saved as Ex34-
b.amw.)

E Click the Bayesian button  to perform the latent structure analysis. The results of the 
latent structure analysis will not be presented here.
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Introduction

Mixture modeling is appropriate when you have a model that is incorrect for an entire 
population, but where the population can be divided into subgroups in such a way that 
the model is correct in each subgroup.

When Amos performs mixture modeling, it allows you to assign some cases to 
groups before the analysis starts. Example 34 shows how to do that. In the present 
example, all cases are unclassified at the start of the mixture modeling analysis.

About the Data

This example uses the Anderson (1935) iris data that was used in Example 34. This 
time, however, we will not use the iris3.sav dataset, which contains species 
information for 30 of the 150 flowers. Instead, we will use the iris2.sav dataset, which 
contains no species information at all. That is the difference between Example 34 and 
the present example: In Example 34, some cases were pre-classified; in the present 
example, no cases are pre-classified. The following figure shows a portion of the 
iris2.sav dataset.
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Notice that the dataset contains a Species column, even though that column is empty. 
It is important that the Species column be present even if it contains no values. This is 
because Amos allows for the possibility that you might already know the species of 
some cases (as in Example 34). The variable that is used for classifying cases does not 
actually have to be named Species. Any variable name will do. The variable does, 
however, have to be a string (non-numeric) variable.

Performing the Analysis

E From the menus, choose File → New to start a new path diagram.

E From the menus, choose Analyze → Manage Groups.
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E Click New to create a second group.

E Click New once more to create a third group.

E Click Close.

This example fits a three-group mixture model. When you aren’t sure how many 
groups there are, you can run the program multiple times. Run the program once to fit 
a two-group model, then again to fit a three-group model, and so on.
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Specifying the Data File

E From the menus, choose File → Data Files.

E Click Group number 1 to select the first row.

E Click File Name, select the iris2.sav file that is in the Amos Examples directory, and 
click Open.

E Click Grouping Variable and double-click Species in the Choose a Grouping Variable 
dialog box. This tells the program that the Species variable will be used to distinguish 
one group from another.
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E Repeat the preceding steps for Group number 2, specifying the same data file (iris2.sav) 
and the same grouping variable (Species).

E Repeat the preceding steps once more for Group number 3, specifying the same data file 
(iris2.sav) and the same grouping variable (Species).
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E Select Assign cases to groups (a check mark will appear next to it).

So far, this has been just like any ordinary multiple-group analysis except for the check 
mark next to Assign cases to groups. That check mark turns this into a mixture 
modeling analysis. The check mark tells Amos to assign a flower to a group if the 
grouping variable in the data file does not already assign it to a group. Notice that it 
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was not necessary to click Group Value to specify a value for the grouping variable. The 
data file contains no values for the grouping variable (Species), so the program 
automatically constructed the following Species values for the three groups: Cluster1, 
Cluster2, and Cluster3. 

E Click OK to close the Data Files dialog box.

Specifying the Model

We will use a saturated model for the variables PetalLength and PetalWidth. The 
scatterplot in Example 34 suggests that these two variables will allow the program to 
do a good job of classifying the flowers according to species.

Note that you are not limited to saturated models when doing mixture modeling. 
You can use a factor analysis model, a regression model, or any other kind of model. 
Example 36 demonstrates mixture modeling with a regression model.

E Draw the following path diagram:

E From the menus, choose View → Analysis Properties.

E Select Estimate means and intercepts (a check mark will appear next to it).
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Constraining the Parameters

In this example, variances and covariances will be required to be invariant across 
groups. This is the assumption of homogeneity of variances and covariances that is 
often made in discriminant analysis and some kinds of clustering. In principle, the 
assumption of homogeneity of variances and covariances is not necessary in mixture 
modeling. The reason we will make the assumption here is that, for this example, the 
algorithm in Amos fails without that assumption. (It should be noted that the scatterplot 
in Example 34 suggests that the assumption is violated.)
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E Right-click PetalLength in the path diagram, choose Object Properties from the popup 
menu, and enter the parameter name, v1, in the Variance text box.

While the Object Properties dialog is still open, click PetalWidth in the path diagram.

E While the Object Properties dialog box is still open, click PetalWidth in the path 
diagram.

E In the Object Properties dialog box, enter the parameter name, v2, in the Variance text 
box.

E While the Object Properties dialog box is still open, click the double-headed arrow that 
represents the covariance between PetalLength and PetalWidth.



548

Example 35

E In the Object Properties dialog box, enter the parameter name, c12, in the Covariance 
text box.

The path diagram should now look like the following figure. (This path diagram is 
saved as Ex35-a.amw.)

Fitting the Model

E Click  on the toolbar.

or

E From the menus, choose Analyze → Bayesian Estimation.

Note: The  button is disabled because, in mixture modeling, you can perform only 
Bayesian estimation.
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After the Bayesian SEM window opens, wait until the unhappy face  changes into 
a happy face . The table of estimates in the Bayesian SEM window should then look 
something like this:

The Bayesian SEM window displays all of the parameter estimates that you would get 
in an ordinary three-group analysis. The table displays the estimates for one group at a 
time. You can switch from one group to another by clicking the tabs at the top of the 
table. In this example, the model parameters include only means, variances, and 
covariances. In a more complicated model, there would also be estimates of regression 
weights and intercepts.
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In a mixture modeling analysis, you also get an estimate of the proportion of the 
population that lies in each group. In the preceding figure, the proportion of setosa 
flowers in the population is estimated to be 0.306.

E To view the posterior distribution of a population proportion, right-click the row that 
contains the proportion and choose Show Posterior from the popup menu.

The graph of the posterior distribution in the Posterior window shows that the 
proportion of flowers that belong in Group number 1 is certainly between 0.15 and 
0.45. There is a very high probability that the proportion is between 0.25 and 0.35.
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Classifying Individual Cases

To obtain probabilities of group membership for each individual flower:

E Click the Posterior Predictive button .

or

E From the menus, choose View → Posterior Predictive.

For each flower, the Posterior Predictive Distributions window shows the probability 
that the value of the Species variable is Cluster1, Cluster2, or Cluster3.
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The first 50 cases, which we know to be examples of setosa, are placed in Group 
number 3 with a probability of 1, so Group number 3 clearly contains setosa flowers. 
Cases 51 through 100 fall mainly into Group number 2, so Group number 2 clearly 
contains versicolor flowers. Similarly, although the preceding figure does not show it, 
cases 101 through 150 are assigned mainly to Group number 1, so Group number 1 
clearly contains virginica flowers.
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Latent Structure Analysis

There is a variation of mixture modeling called latent structure analysis in which 
observed variables are required to be independent within each group.

E To require that PetalLength and PetalWidth be uncorrelated and therefore (because 
they are multivariate normally distributed) independent, remove the double-headed 
arrow that connects them in the path diagram. The resulting path diagram is shown 
here. (This path diagram is saved as the file, Ex35-b.amw.)

E Optionally, remove the constraints on the variances by deleting the parameter names, 
v1 and v2. (The resulting path diagram is saved as Ex35-c.amw.)

E After deleting the double-headed arrow and possibly removing the constraints on the 
variances, click the Bayesian button  to perform the latent structure analysis. The 
results of the latent structure analysis will not be reported here.
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Label Switching

If you attempt to replicate the analysis in this example, it is possible that you will get 
the results that are reported here but with the group names permuted. The results 
reported here for Group number 1 might correspond to the results you get for Group 
number 2 or Group number 3. This is sometimes called label switching (Chung, 
Loken, and Schafer, 2004). Label switching is not really a problem unless it occurs 
during the course of a single analysis. Unfortunately, label switching can in fact occur 
in the middle of an analysis. When label switching occurs, it is usually revealed by 
trace plots for individual parameters. To display a trace plot during Bayesian 
estimation:

E Right-click a parameter in the Bayesian SEM window and choose Show Posterior from 
the popup menu.

E In the Posterior window, select Trace.

Label switching did not occur in the analysis of the present example. The following 
figure, from another analysis, shows a trace plot that is typical of label switching. This 
trace plot came from an analysis of data with two clusters of cases. In one cluster, the 
mean of a variable called X was about 4. In the other cluster, the mean of the X variable 
was about 17. The trace plot shows that, in the group called Group number 1, the 
sampled values of the mean of X stayed close to 4 most of the time until about the 
5,000-th iteration of the MCMC algorithm. At about the 5,000-th iteration, sampled 
values started fluctuating around 17. This abrupt shift in the trace plot is evidence that 
the group labels (Group number 1 and Group number 2) were switched at about the 
5,000-th iteration. The trace plot shows that this label switching occurred several times 
during the first 20,000 iterations of the MCMC algorithm.
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Label switching can be revealed by a multi-model posterior distribution for one or 
more parameters. The preceding trace plot corresponds to the following posterior 
distribution estimate.

The preceding graph shows that the mean of a parameter’s posterior distribution may 
not be a meaningful estimate in a mixture modeling analysis when label switching 
occurs. Some methods for preventing label switching have been proposed (Celeux, 
Hurn, and Robert, 2000; Frühwirth-Schnatter, 2004; Jasra, Holmes, and Stephens, 
2005; Stephens, 2000). Chung, Loken, and Schafer (2004) suggest that pre-assigning 
even one or two cases to groups can be effective in eliminating label switching. Amos 
allows pre-assigning cases to groups, as shown in Example 34. Amos 19 does not 
implement any other method for preventing label switching.
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Mixture Regression Modeling

Introduction

Mixture regression modeling (Ding, 2006) is appropriate when you have a regression 
model that is incorrect for an entire population, but where the population can be 
divided into subgroups in such a way that the regression model is correct in each 
subgroup.

About the Data

Two artificial datasets will be used to explain mixture regression.

First Dataset

The following dataset is in the file DosageAndPerformance1.sav. Dosage is the 
intensity of some treatment. Performance is just some performance measure. Group 
is a string (non-numeric) variable whose role in mixture regression analysis will be 
explained later.



558

Example 36

A scatterplot of dosage and performance shows two distinct groups of people in the 
sample. In one group, performance improves as dosage goes up. In the other group, 
performance gets worse as dosage goes up.
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It would be a mistake to try to fit a single regression line to the whole sample. On the 
other hand, two straight lines, one for each group, would fit the data well. This is a job 
for mixture regression modeling. A mixture regression analysis would attempt to 
divide the sample up into groups and to fit a separate regression line to each group.

Second Dataset

The following dataset, in the file DosageAndPerformance2.sav, also contains data on 
the variables dosage, performance, and group.

Again, a scatterplot of the data shows evidence of two groups, with each group 
requiring its own regression line. In either group by itself, an increase of one unit in 
dosage is associated with an increase of about two units in performance, so that the 
slope of the regression line is about 2 within each group. On the other hand, the two 
groups have different intercepts. At any particular dosage level, performance is 5 
points or so higher in one group than in the other. A mixture regression analysis of this 
dataset would attempt to divide the sample up into groups and to fit a separate 
regression line to each group.
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The Group Variable in the Dataset

Both of the datasets just described include a string (non-numeric) variable called group 
that contains no data. In a mixture regression analysis, Amos will use the group 
variable to classify individual cases. (The fact that the variable is called group is not 
important. Any variable name will do; however, it does have to be a string variable.) 

If some cases have already been assigned to groups before the analysis starts, you 
can put the group names in the group column of the dataset. For example, if you know 
ahead of time (before the mixture regression analysis starts) that the sample contains 
high performers and low performers and you know that the first two people in the 
sample are high performers and that the next three people are low performers, then you 
can enter that information in the group column of the data table in the following way:
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The program will then use the five cases that have been pre-classified to assist in 
classifying the remaining cases. Pre-assigning selected individual cases to groups is 
mentioned here only as a possibility. In the present example, no cases will be pre-
assigned to groups.

Performing the Analysis

Only the DosageAndPerformance2.sav dataset will be analyzed in this example.

E From the menus, choose File → New to start a new path diagram.

E From the menus, choose Analyze → Manage Groups.
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E Click New to create a second group.

E Click Close.

This example fits a two-group mixture regression model. When you aren’t sure how 
many groups there are, you can run the program multiple times. Run the program once 
to fit a two-group model, then again to fit a three-group model, and so on.
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Specifying the Data File

E From the menus, choose File → Data Files.

E Click Group number 1 to select that row.

E Click File Name, select the DosageAndPerformance2.sav file that is in the Amos 
Examples directory, and click Open.

E Click Grouping Variable and double-click group in the Choose a Grouping Variable 
dialog box. This tells the program that the variable called group will be used to 
distinguish one group from another.
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E Repeat the preceding steps for Group number 2, specifying the same data file 
(DosageAndPerformance2.sav) and the same grouping variable (group).
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E Select Assign cases to groups (a check mark will appear next to it). 

So far, this has been just like any ordinary multiple-group analysis except for the check 
mark next to Assign cases to groups. That check mark turns this into a mixture 
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modeling analysis. The check mark tells Amos to assign a case to a group if the 
grouping variable in the data file does not already assign it to a group. Notice that it 
was not necessary to click Group Value to specify a value for the grouping variable. The 
data file contains no values for the grouping variable (group), so the program 
automatically constructed values for the group variable: Cluster1 for cases in Group 
number 1, and Cluster2 for cases in Group number 2.

E Click OK to close the Data Files dialog box.

Specifying the Model

E Draw a path diagram for the regression model, as follows. (This path diagram is saved 
as Ex36-a.amw.)

E From the menus, choose View → Analysis Properties.

E Select Estimate means and intercepts (a check mark will appear next to it). 
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Fitting the Model

E Click  on the toolbar.

or

E From the menus, choose Analyze → Bayesian Estimation.

Note: The  button is disabled because, in mixture modeling, you can perform only 
Bayesian estimation.
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After the Bayesian SEM window opens, wait until the unhappy face  changes into 
a happy face . The table of estimates in the Bayesian SEM window should then look 
something like this:

The Bayesian SEM window contains all of the parameter estimates that you would get 
in an ordinary multiple-group regression analysis. There is a separate table of estimates 
for each group. You can switch from group to group by clicking the tabs just above the 
table of estimates.
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The bottom row of the table contains an estimate of the proportion of the population 
that lies in an individual group. The preceding figure, which displays estimates for 
Group number 1, shows that the proportion of the population in Group number 1 is 
estimated to be 0.247. To see the estimated posterior distribution of that population 
proportion, right-click the proportion’s row in the table and choose Show Posterior 
from the popup menu.
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The graph in the Posterior window shows that the proportion of the population in 
Group number 1 is practically guaranteed to be somewhere between 0.15 and 0.35.

Let’s compare the regression weight and the intercept in Group number 1 with the 
corresponding estimates in Group number 2. In Group number 1, the regression weight 
estimate is 2.082 and the intercept estimate is 5.399. In Group number 2, the regression 
weight estimate (1.999) is about the same as in Group number 1 while the intercept 
estimate (9.955) is substantially higher than in Group number 1.
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Classifying Individual Cases

To obtain probabilities of group membership for each individual case:

E Click the Posterior Predictive button .

or

E From the menus, choose View → Posterior Predictive.

For each case, the Posterior Predictive Distributions window shows the probability that 
the group variable takes on the value Cluster1 or Cluster2.  Case 1 is estimated to have 
a 0.88 probability of being in Group number 1 and a 0.12 probability of being in Group 
number 2. Recall that the first group has an intercept of about 5.399 while the second 
group has an intercept of about 9.955, so Group number 1 is the low performing group. 
Therefore, there is an 88 percent chance that the first person in the sample is in the low 
performing group and a 12 percent chance that that person is in the high performing 
group.
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Improving Parameter Estimates

You can improve the parameter estimates (and also improve Amos’s ability to form 
clusters) by reducing the number of parameters that need to be estimated. As we have 
seen, the slope of the regression line is about the same for the two groups. Also, the 
variability about each regression line appears to be about the same for the two groups. 
It is possible to incorporate into the mixture modeling analysis the hypothesis that the 
slopes and the error variances are the same for the two groups, thereby reducing the 
number of distinct parameters to be estimated. To do this:

E On the path diagram, right-click the single-headed arrow that connects dosage and 
performance, choose Object Properties from the popup menu, and enter the parameter 
name, b, in the Regression weight text box.

E While the Object Properties dialog box is still open, click E1 in the path diagram.

E In the Object Properties dialog box, enter the parameter name, v, in the Variance text 
box.
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The path diagram should now look like the following figure. (This path diagram is 
saved as Ex36-b.amw.)

After constraining the slope and error variance to be the same for the two groups, you 
can repeat the mixture modeling analysis by clicking the Bayesian button . The 
results of that analysis will not be presented here.
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Prior Distribution of Group Proportions

For the prior distribution of group proportions, Amos uses a Dirichlet distribution with 
parameters that you can specify. By default, the Dirichlet parameters are 4, 4, ….

E To specify the Dirichlet parameters, right-click on a group proportion’s estimate in the 
Bayesian SEM window and choose Show Prior from the popup menu.
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Label Switching

It is possible that the results reported here for Group number 1 will match the results 
that you get for Group number 2, and that the results reported here for Group number 
2 will match those that you get for Group number 1. In other words, your results may 
match the results reported here, but with the group names reversed. This is sometimes 
called label switching (Chung, Loken, and Schafer, 2004). Label switching is 
discussed further at the end of Example 35.
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A
Notation

q = the number of parameters

 = the vector of parameters (of order q)

G = the number of groups

 = the number of observations in group g

 = the total number of observations in all groups combined

 = the number of observed variables in group g

 = the number of sample moments in group g. When means and intercepts are 
explicit model parameters, the relevant sample moments are means, 
variances, and covariances, so that . Otherwise, 
only sample variances and covariances are counted so that 

.

 = the number of sample moments in all groups combined

 = the number of degrees of freedom for testing the model

 = the r-th observation on the i-th variable in group g

 = the r-th observation in group g

 = the sample covariance matrix for group g

γ

N g( )

N N g( )

g 1=

G

∑=

p g( )

p* g( )

p* g( ) p g( ) p g( ) 3+( ) 2⁄=
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x r
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S g( )
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 = the covariance matrix for group g, according to the model

 = the mean vector for group g, according to the model

 = the population covariance matrix for group g

 = the population mean vector for group g

 = the  distinct elements of  arranged in a single column 
vector

r = the non-negative integer specified by the ChiCorrect method. By default r = G. 
When the Emulisrel6 method is used, r = G and cannot be changed by using 
ChiCorrect.

n = N – r 

 = the vector of order p containing the sample moments for all groups; that is,  
contains the elements of  and also (if means and intercepts are 
explicit model parameters) .

 = the vector of order p containing the population moments for all groups; that is, 
 contains the elements of  and also (if means and intercepts 

are explicit model parameters) . The ordering of the elements of 
 must match the ordering of the elements of .

 = the vector of order p containing the population moments for all groups 
according to the model; that is,  contains the elements of 

 and also (if means and intercepts are explicit model 
parameters) . The ordering of the elements of  must 
match the ordering of the elements of .

 = the function (of �) that is minimized in fitting the model to the sample

 = the value of � that minimizes 
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B
Discrepancy Functions

Amos minimizes discrepancy functions (Browne, 1982, 1984) of the form:

(D1)

Different discrepancy functions are obtained by changing the way f is defined. If 
means and intercepts are unconstrained and do not appear as explicit model 
parameters,  and  will be omitted and f will be written .

The discrepancy functions  and  are obtained by taking f to be:

Except for an additive constant that depends only on the sample size,  is –2 times 
the Kullback-Leibler information quantity (Kullback and Leibler, 1951). Strictly 
speaking,  and  do not qualify as discrepancy functions according to 
Browne’s definition because .

For maximum likelihood estimation (ML), , and  are obtained by taking f to be:
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(D2)

For generalized least squares estimation (GLS), , and  are obtained by 
taking f to be:

(D3)

For asymptotically distribution-free estimation (ADF), , and  are obtained 
by taking f to be:

(D4)

where the elements of  are given by Browne (1984, Equations 3.1–3.4):
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For scale-free least squares estimation (SLS), , and  are obtained by taking 
f to be:

(D5)

where .

For unweighted least squares estimation (ULS), , and  are obtained by 
taking f to be:

(D6)

The Emulisrel6 method in Amos can be used to replace (D1) with:

(D1a)

F is then calculated as .

When G = 1 and r = 1, (D1) and (D1a) are equivalent, giving:

For maximum likelihood, asymptotically distribution-free, and generalized least 
squares estimation, both (D1) and (D1a) have a chi-square distribution for correctly 
specified models under appropriate distributional assumptions. Asymptotically, (D1) 
and (D1a) are equivalent; however, both formulas can exhibit some inconsistencies in 
finite samples. 
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Suppose you have two independent samples and a model for each. Furthermore, 
suppose that you analyze the two samples simultaneously, but that, in doing so, you 
impose no constraints requiring any parameter in one model to equal any parameter in 
the other model. Then, if you minimize (D1a), the parameter estimates obtained from 
the simultaneous analysis of both groups will be the same as from separate analyses of 
each group alone. 

Furthermore, the discrepancy function (D1a) obtained from the simultaneous 
analysis will be the sum of the discrepancy functions from the two separate analyses. 
Formula (D1) does not have this property when r is nonzero. Using formula (D1) to do 
a simultaneous analysis of the two groups will give the same parameter estimates as 
two separate analyses, but the discrepancy function from the simultaneous analysis 
will not be the sum of the individual discrepancy functions.

On the other hand, suppose you have a single sample to which you have fitted some 
model using Amos. Now suppose that you arbitrarily split the sample into two groups 
of unequal size and perform a simultaneous analysis of both groups, employing the 
original model for both groups and constraining each parameter in the first group to be 
equal to the corresponding parameter in the second group. If you have minimized (D1) 
in both analyses, you will get the same results in both. However, if you use (D1a) in 
both analyses, the two analyses will produce different estimates and a different 
minimum value for F.

All of the inconsistencies just pointed out can be avoided by using (D1) with the 
choice r = 0, so that (D1) becomes:

( ) ( ) FNFNC
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g
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Measures of Fit

Model evaluation is one of the most unsettled and difficult issues connected with 
structural modeling. Bollen and Long (1993), MacCallum (1990), Mulaik, et al. 
(1989), and Steiger (1990) present a variety of viewpoints and recommendations on 
this topic. Dozens of statistics, besides the value of the discrepancy function at its 
minimum, have been proposed as measures of the merit of a model. Amos calculates 
most of them.

Fit measures are reported for each model specified by the user and for two 
additional models called the saturated model and the independence model. 

In the saturated model, no constraints are placed on the population moments. The 
saturated model is the most general model possible. It is a vacuous model in the 
sense that it is guaranteed to fit any set of data perfectly. Any Amos model is a 
constrained version of the saturated model. 

The independence model goes to the opposite extreme. In the independence 
model, the observed variables are assumed to be uncorrelated with each other. 
When means are being estimated or constrained, the means of all observed variables 
are fixed at 0. The independence model is so severely and implausibly constrained 
that you would expect it to provide a poor fit to any interesting set of data. 

It frequently happens that each one of the models that you have specified can be so 
constrained as to be equivalent to the independence model. If this is the case, the 
saturated model and the independence model can be viewed as two extremes between 
which your proposed models lie.

For every estimation method except maximum likelihood, Amos also reports fit 
measures for a zero model, in which every parameter is fixed at 0.

PCLOSE
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Measures of Parsimony

Models with relatively few parameters (and relatively many degrees of freedom) are 
sometimes said to be high in parsimony, or simplicity. Models with many parameters 
(and few degrees of freedom) are said to be complex, or lacking in parsimony. This 
use of the terms simplicity and complexity does not always conform to everyday usage. 
For example, the saturated model would be called complex, while a model with an 
elaborate pattern of linear dependencies but with highly constrained parameter values 
would be called simple.

While one can inquire into the grounds for preferring simple, parsimonious models 
(such as Mulaik, et al., 1989), there does not appear to be any disagreement that 
parsimonious models are preferable to complex ones. When it comes to parameters, all 
other things being equal, less is more. At the same time, well-fitting models are 
preferable to poorly fitting ones. Many fit measures represent an attempt to balance 
these two conflicting objectives—simplicity and goodness of fit.

In the final analysis, it may be, in a sense, impossible to define one best way to 
combine measures of complexity and measures of badness-of-fit in a single 
numerical index, because the precise nature of the best numerical trade-off 
between complexity and fit is, to some extent, a matter of personal taste. The 
choice of a model is a classic problem in the two-dimensional analysis of 
preference. (Steiger, 1990, p. 179)

NPAR 

NPAR is the number of distinct parameters (q) being estimated. For example, two 
regression weights that are required to be equal to each other count as one parameter, 
not two.

Note: Use the \npar text macro to display the number of parameters in the output path 
diagram.

DF

DF is the number of degrees of freedom for testing the model

qpd −==df
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where p is the number of sample moments and q is the number of distinct parameters. 
Rigdon (1994a) gives a detailed explanation of the calculation and interpretation of 
degrees of freedom.

Note: Use the \df text macro to display the degrees of freedom in the output path 
diagram.

PRATIO

The parsimony ratio (James, Mulaik, and Brett, 1982; Mulaik, et al., 1989) expresses 
the number of constraints in the model being evaluated as a fraction of the number of 
constraints in the independence model

where d is the degrees of freedom of the model being evaluated and  is the degrees 
of freedom of the independence model. The parsimony ratio is used in the calculation 
of PNFI and PCFI (see “Parsimony Adjusted Measures” on p. 598).

Note: Use the \pratio text macro to display the parsimony ratio in the output path 
diagram.

Minimum Sample Discrepancy Function

The following fit measures are based on the minimum value of the discrepancy.

CMIN

CMIN is the minimum value, , of the discrepancy, C (see Appendix B).

Note: Use the \cmin text macro to display the minimum value  of the discrepancy 
function C in the output path diagram.

P

P is the probability of getting as large a discrepancy as occurred with the present 
sample (under appropriate distributional assumptions and assuming a correctly 

id
d=PRATIO

di
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Ĉ
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specified model). That is, P is a “p value” for testing the hypothesis that the model fits 
perfectly in the population.

One approach to model selection employs statistical hypothesis testing to eliminate 
from consideration those models that are inconsistent with the available data. 
Hypothesis testing is a widely accepted procedure, and there is a lot of experience in 
its use. However, its unsuitability as a device for model selection was pointed out early 
in the development of analysis of moment structures (Jöreskog, 1969). It is generally 
acknowledged that most models are useful approximations that do not fit perfectly in 
the population. In other words, the null hypothesis of perfect fit is not credible to begin 
with and will, in the end, be accepted only if the sample is not allowed to get too big.

If you encounter resistance to the foregoing view of the role of hypothesis testing in 
model fitting, the following quotations may come in handy. The first two predate the 
development of structural modeling and refer to other model fitting problems.

The power of the test to detect an underlying disagreement between theory and 
data is controlled largely by the size of the sample. With a small sample an 
alternative hypothesis which departs violently from the null hypothesis may still 
have a small probability of yielding a significant value of . In a very large 
sample, small and unimportant departures from the null hypothesis are almost 
certain to be detected. (Cochran, 1952)

If the sample is small, then the  test will show that the data are ‘not 
significantly different from’ quite a wide range of very different theories, while 
if the sample is large, the  test will show that the data are significantly 
different from those expected on a given theory even though the difference may 
be so very slight as to be negligible or unimportant on other criteria. (Gulliksen 
and Tukey, 1958, pp. 95–96)

Such a hypothesis [of perfect fit] may be quite unrealistic in most empirical work 
with test data. If a sufficiently large sample were obtained this statistic would, 
no doubt, indicate that any such non-trivial hypothesis is statistically untenable. 
(Jöreskog, 1969, p. 200)

...in very large samples virtually all models that one might consider would have 
to be rejected as statistically untenable.... In effect, a nonsignificant chi-square 
value is desired, and one attempts to infer the validity of the hypothesis of no 
difference between model and data. Such logic is well-known in various 
statistical guises as attempting to prove the null hypothesis. This procedure 
cannot generally be justified, since the chi-square variate v can be made small by 
simply reducing sample size. (Bentler and Bonett, 1980, p. 591)

χ2

χ2

χ2

χ2
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Our opinion...is that this null hypothesis [of perfect fit] is implausible and that it 
does not help much to know whether or not the statistical test has been able to 
detect that it is false. (Browne and Mels, 1992, p. 78).

See also “PCLOSE” on p. 591.

Note: Use the \p text macro for displaying this p value in the output path diagram.

CMIN/DF

CMIN/DF is the minimum discrepancy, , (see Appendix B) divided by its degrees 
of freedom.

Several writers have suggested the use of this ratio as a measure of fit. For every 
estimation criterion except for ULS and SLS, the ratio should be close to 1 for correct 
models. The trouble is that it isn’t clear how far from 1 you should let the ratio get 
before concluding that a model is unsatisfactory.

Rules of Thumb

...Wheaton et al. (1977) suggest that the researcher also compute a relative chi-
square ( ).... They suggest a ratio of approximately five or less ‘as 
beginning to be reasonable.’ In our experience, however,  to degrees of 
freedom ratios in the range of 2 to 1 or 3 to 1 are indicative of an acceptable fit 
between the hypothetical model and the sample data. (Carmines and McIver, 
1981, p. 80)

...different researchers have recommended using ratios as low as 2 or as high as 
5 to indicate a reasonable fit. (Marsh and Hocevar, 1985).

...it seems clear that a  ratio > 2.00 represents an inadequate fit. (Byrne, 
1989, p. 55).

Note: Use the \cmindf text macro to display the value of CMIN/DF in the output path 
diagram.

Ĉ

d
Ĉ

χ2 df⁄
χ2

χ2 df⁄
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FMIN

FMIN is the minimum value, , of the discrepancy, F (see Appendix B).

Note: Use the \fmin text macro to display the minimum value  of the discrepancy 
function F in the output path diagram.

Measures Based On the Population Discrepancy

Steiger and Lind (1980) introduced the use of the population discrepancy function as 
a measure of model adequacy. The population discrepancy function, , is the value 
of the discrepancy function obtained by fitting a model to the population moments 
rather than to sample moments. That is, 

in contrast to

Steiger, Shapiro, and Browne (1985) showed that, under certain conditions,  
has a noncentral chi-square distribution with d degrees of freedom and noncentrality 
parameter . The Steiger-Lind approach to model evaluation centers 
around the estimation of  and related quantities. 

This section of the User’s Guide relies mainly on Steiger and Lind (1980) and 
Steiger, Shapiro, and Browne (1985). The notation is primarily that of Browne and 
Mels (1992).

NCP

 is an estimate of the noncentrality parameter, 
.

The columns labeled LO 90 and HI 90 contain the lower limit ( ) and upper limit 
( ) of a 90% confidence interval, on δ. is obtained by solving

F̂

F̂

F0

F0 min F α γ( ) α0,( )[ ]
γ

=

F̂ min F α γ( ) a,( )[ ]
γ

=

Ĉ nF̂=

δ C nF= =
F0

NCP max Ĉ d– 0,( )=
δ C0 nF0= =

δL
δU δL

( ) 95.,ˆ =Φ dC δ
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for , and  is obtained by solving

for , where  is the distribution function of the noncentral chi-squared 
distribution with noncentrality parameter  and d degrees of freedom.

Note: Use the \ncp text macro to display the value of the noncentrality parameter 
estimate in the path diagram, \ncplo to display the lower 90% confidence limit, and 
\ncphi for the upper 90% confidence limit.

F0

 is an estimate of .

The columns labeled LO 90 and HI 90 contain the lower limit and upper limit of a 90% 
confidence interval for .

 

Note: Use the \f0 text macro to display the value of  in the output path diagram, \f0lo 
to display its lower 90% confidence estimate, and \f0hi to display the upper 90% 
confidence estimate.

RMSEA

 incorporates no penalty for model complexity and will tend to favor models with 
many parameters. In comparing two nested models,  will never favor the simpler 
model. Steiger and Lind (1980) suggested compensating for the effect of model 
complexity by dividing  by the number of degrees of freedom for testing the model. 
Taking the square root of the resulting ratio gives the population root mean square 

δ δU

( ) 05.,|ˆ =Φ dC δ

δ Φ x δ d,( )
δ

F0 F̂0 max Ĉ d–
n

------------- 0,⎝ ⎠
⎛ ⎞ NCP

n
-----------= = = δ

n
--- F0=

F0

n
Lδ= 90 LO

n
Uδ

= 90 HI

F̂0

F0
F0

F0
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error of approximation, called RMS by Steiger and Lind, and RMSEA by Browne and 
Cudeck (1993).

The columns labeled LO 90 and HI 90 contain the lower limit and upper limit of a 90% 
confidence interval on the population value of RMSEA. The limits are given by

Rule of Thumb

Practical experience has made us feel that a value of the RMSEA of about 0.05 or 
less would indicate a close fit of the model in relation to the degrees of freedom. 
This figure is based on subjective judgment. It cannot be regarded as infallible or 
correct, but it is more reasonable than the requirement of exact fit with the 
RMSEA = 0.0. We are also of the opinion that a value of about 0.08 or less for the 
RMSEA would indicate a reasonable error of approximation and would not want 
to employ a model with a RMSEA greater than 0.1. (Browne and Cudeck, 1993)

Note: Use the \rmsea text macro to display the estimated root mean square error of 
approximation in the output path diagram, \rmsealo for its lower 90% confidence 
estimate, and \rmseahi for its upper 90% confidence estimate.

d
F0RMSEA population =

d
F0
ˆ

RMSEA estimated =

d
nLδ= 90 LO

d
nUδ

= 90 HI
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PCLOSE

 is a p value for testing the null hypothesis that the 
population RMSEA is no greater than 0.05. 

By contrast, the p value in the P column (see “P” on p. 585) is for testing the hypothesis 
that the population RMSEA is 0.

Based on their experience with RMSEA, Browne and Cudeck (1993) suggest that a 
RMSEA of 0.05 or less indicates a close fit. Employing this definition of close fit, 
PCLOSE gives a test of close fit while P gives a test of exact fit.

Note: Use the \pclose text macro to display the p value for close fit of the population 
RMSEA in the output path diagram.

Information-Theoretic Measures

Amos reports several statistics of the form  or , where k is some positive 
constant. Each of these statistics creates a composite measure of badness of fit 
( or ) and complexity (q) by forming a weighted sum of the two. Simple models 
that fit well receive low scores according to such a criterion. Complicated, poorly 
fitting models get high scores. The constant k determines the relative penalties to be 
attached to badness of fit and to complexity. 

The statistics described in this section are intended for model comparisons and not 
for the evaluation of an isolated model.

All of these statistics were developed for use with maximum likelihood estimation. 
Amos reports them for GLS and ADF estimation as well, although it is not clear that 
their use is appropriate there.

AIC

The Akaike information criterion (Akaike, 1973, 1987) is given by

PCLOSE 1 Φ Ĉ .052nd d,( )–=

05.RMSEA :0 ≤H

0RMSEA :0 =H

Ĉ kq+ F̂ kq+

Ĉ F̂

qC 2ˆAIC +=

P \* Charformat
P \* Charformat
ECVI \* Charformat
ECVI \* Charformat
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See also “ECVI” on p. 593.

Note: Use the \aic text macro to display the value of the Akaike information criterion 
in the output path diagram.

BCC

The Browne-Cudeck (1989) criterion is given by

where  if the Emulisrel6 command has been used, or  if it 
has not.

BCC imposes a slightly greater penalty for model complexity than does AIC. BCC 
is the only measure in this section that was developed specifically for analysis of 
moment structures. Browne and Cudeck provided some empirical evidence suggesting 
that BCC may be superior to more generally applicable measures. Arbuckle (in 
preparation) gives an alternative justification for BCC and derives the above formula 
for multiple groups.

See also “MECVI” on p. 594.

Note: Use the \bcc text macro to display the value of the Browne-Cudeck criterion in 
the output path diagram.

BIC

The Bayes information criterion (Schwarz, 1978; Raftery, 1993) is given by the 
formula

In comparison to the AIC, BCC, and CAIC, the BIC assigns a greater penalty to model 
complexity and, therefore, has a greater tendency to pick parsimonious models. The 
BIC is reported only for the case of a single group where means and intercepts are not 
explicit model parameters.
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Note: Use the \bic text macro to display the value of the Bayes information criterion in 
the output path diagram.

CAIC

Bozdogan’s (1987) CAIC (consistent AIC) is given by the formula

CAIC assigns a greater penalty to model complexity than either AIC or BCC but not as 
great a penalty as does BIC. CAIC is reported only for the case of a single group where 
means and intercepts are not explicit model parameters. 

Note: Use the \caic text macro to display the value of the consistent AIC statistic in the 
output path diagram.

ECVI

Except for a constant scale factor, ECVI is the same as AIC.

The columns labeled LO 90 and HI 90 give the lower limit and upper limit of a 90% 
confidence interval on the population ECVI:

See also “AIC” on p. 591.

Note: Use the \ecvi text macro to display the value of the expected cross-validation 
index in the output path diagram, \ecvilo to display its lower 90% confidence estimate, 
and \ecvihi for its upper 90% confidence estimate.

( )( )1lnˆCAIC 1 ++= NqC

( )
n
qF

n
2ˆAIC1ECVI +==

n
qdL 2 90 LO ++= δ

n
qdU 2 90 HI ++

=
δ

AIC
AIC
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MECVI

Except for a scale factor, MECVI is identical to BCC.

where  if the Emulisrel6 command has been used, or  if it 
has not.

See also “BCC” on p. 592.

Note: Use the \mecvi text macro to display the modified ECVI statistic in the output 
path diagram.

Comparisons to a Baseline Model

Several fit measures encourage you to reflect on the fact that, no matter how badly your 
model fits, things could always be worse.

Bentler and Bonett (1980) and Tucker and Lewis (1973) suggested fitting the 
independence model or some other very badly fitting baseline model as an exercise to 
see how large the discrepancy function becomes. The object of the exercise is to put 
the fit of your own model(s) into some perspective. If none of your models fit very 
well, it may cheer you up to see a really bad model. For example, as the following 
output shows, Model A from Example 6 has a rather large discrepancy ( ) 
in relation to its degrees of freedom. On the other hand, 71.544 does not look so bad 
compared to 2131.790 (the discrepancy for the independence model).
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This things-could-be-much-worse philosophy of model evaluation is incorporated into 
a number of fit measures. All of the measures tend to range between 0 and 1, with 
values close to 1 indicating a good fit. Only NFI (described below) is guaranteed to be 
between 0 and 1, with 1 indicating a perfect fit. (CFI is also guaranteed to be between 
0 and 1, but this is because values bigger than 1 are reported as 1, while values less than 
0 are reported as 0.)

The independence model is only one example of a model that can be chosen as the 
baseline model, although it is the one most often used and the one that Amos uses. 
Sobel and Bohrnstedt (1985) contend that the choice of the independence model as a 
baseline model is often inappropriate. They suggest alternatives, as did Bentler and 
Bonett (1980), and give some examples to demonstrate the sensitivity of NFI to the 
choice of baseline model.

NFI

The Bentler-Bonett (1980) normed fit index (NFI), or Δ1 in the notation of Bollen 
(1989b) can be written

where  is the minimum discrepancy of the model being evaluated and 
 is the minimum discrepancy of the baseline model.

In Example 6, the independence model can be obtained by adding constraints to any 
of the other models. Any model can be obtained by constraining the saturated model. 
So Model A, for instance, with , is unambiguously in between the 
perfectly fitting saturated model ( ) and the independence model 
( ).

Model NPAR CMIN DF P CMIN/DF

Model A: No Autocorrelation 15 71.544 6 0.000 11.924
Model B: Most General 16 6.383 5 0.271 1.277
Model C: Time-Invariance 13 7.501 8 0.484 0.938
Model D: A and C Combined 12 73.077 9 0.000 8.120
Saturated model 21 0.000 0
Independence model 6 2131.790 15 0.000 142.119

bb F
F

C
C

ˆ
ˆ

1ˆ
ˆ

1NFI 1 −=−=Δ=

Ĉ nF̂=
Cb
ˆ nFb

ˆ=

χ2 71.544=
χ2 0=

χ2 2131.790=
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Looked at in this way, the fit of Model A is a lot closer to the fit of the saturated model 
than it is to the fit of the independence model. In fact, you might say that Model A has 
a discrepancy that is 96.6% of the way between the (terribly fitting) independence 
model and the (perfectly fitting) saturated model.

Rule of Thumb

Since the scale of the fit indices is not necessarily easy to interpret (e.g., the 
indices are not squared multiple correlations), experience will be required to 
establish values of the indices that are associated with various degrees of 
meaningfulness of results. In our experience, models with overall fit indices of 
less than 0.9 can usually be improved substantially. These indices, and the general 
hierarchical comparisons described previously, are best understood by examples. 
(Bentler and Bonett, 1980, p. 600, referring to both the NFI and the TLI)

Note: Use the \nfi text macro to display the normed fit index value in the output path 
diagram.

RFI

Bollen’s (1986) relative fit index (RFI) is given by

Model NPAR CMIN DF P CMIN/DF

Model A: No Autocorrelation 15 71.544 6 0.000 11.924
Model B: Most General 16 6.383 5 0.271 1.277
Model C: Time-Invariance 13 7.501 8 0.484 0.938
Model D: A and C Combined 12 73.077 9 0.000 8.120
Saturated model 21 0.000 0
Independence model 6 2131.790 15 0.000 142.119

966.
790.2131

54.711
790.2131

54.71790.2131 =−=−=NFI

bbbb dF
dF

dC
dC

ˆ
ˆ

1ˆ
ˆ

1RFI 1 −=−== ρ
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where  and d are the discrepancy and the degrees of freedom for the model being 
evaluated, and  and  are the discrepancy and the degrees of freedom for the 
baseline model. 

The RFI is obtained from the NFI by substituting F / d for F. RFI values close to 1 
indicate a very good fit.

Note: Use the \rfi text macro to display the relative fit index value in the output path 
diagram.

IFI

Bollen’s (1989b) incremental fit index (IFI) is given by:

where  and d are the discrepancy and the degrees of freedom for the model being 
evaluated, and  and  are the discrepancy and the degrees of freedom for the 
baseline model. IFI values close to 1 indicate a very good fit.

Note: Use the \ifi text macro to display the incremental fit index value in the output path 
diagram.

TLI

The Tucker-Lewis coefficient (ρ2 in the notation of Bollen, 1989b) was discussed by 
Bentler and Bonett (1980) in the context of analysis of moment structures and is also 
known as the Bentler-Bonett non-normed fit index (NNFI). 

The typical range for TLI lies between 0 and 1, but it is not limited to that range. TLI 
values close to 1 indicate a very good fit.

Note: Use the \tli text macro to display the value of the Tucker-Lewis index in the 
output path diagram.
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Ĉ
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CFI

The comparative fit index (CFI; Bentler, 1990) is given by

where , d, and NCP are the discrepancy, the degrees of freedom, and the 
noncentrality parameter estimate for the model being evaluated, and , , and 

are the discrepancy, the degrees of freedom, and the noncentrality parameter 
estimate for the baseline model.

The CFI is identical to McDonald and Marsh’s (1990) relative noncentrality index 
(RNI)

except that the CFI is truncated to fall in the range from 0 to 1. CFI values close to 1 
indicate a very good fit.

Note: Use the \cfi text macro to display the value of the comparative fit index in the 
output path diagram.

Parsimony Adjusted Measures

James, et al. (1982) suggested multiplying the NFI by a parsimony index so as to take 
into account the number of degrees of freedom for testing both the model being 
evaluated and the baseline model. Mulaik, et al. (1989) suggested applying the same 
adjustment to the GFI. Amos also applies a parsimony adjustment to the CFI.

See also “PGFI” on p. 601.
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Ĉ
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PNFI

The PNFI is the result of applying James, et al.’s (1982) parsimony adjustment to the 
NFI

where d is the degrees of freedom for the model being evaluated, and  is the degrees 
of freedom for the baseline model.

Note: Use the \pnfi text macro to display the value of the parsimonious normed fit index 
in the output path diagram.

PCFI

The PCFI is the result of applying James, et al.’s (1982) parsimony adjustment to the 
CFI:

where d is the degrees of freedom for the model being evaluated, and  is the degrees 
of freedom for the baseline model.

Note: Use the \pcfi text macro to display the value of the parsimonious comparative fit 
index in the output path diagram.

GFI and Related Measures

The GFI and related fit measures are described here.

GFI

The GFI (goodness-of-fit index) was devised by Jöreskog and Sörbom (1984) for ML 
and ULS estimation, and generalized to other estimation criteria by Tanaka and Huba 
(1985). 
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The GFI is given by

where  is the minimum value of the discrepancy function defined in Appendix B and 
 is obtained by evaluating F with , g = 1, 2,...,G. An exception has to be 

made for maximum likelihood estimation, since (D2) in Appendix B is not defined for 
. For the purpose of computing GFI in the case of maximum likelihood 

estimation,  in Appendix B is calculated as

with , where  is the maximum likelihood estimate of . GFI is 
always less than or equal to 1. GFI = 1 indicates a perfect fit.

Note: Use the \gfi text macro to display the value of the goodness-of-fit index in the 
output path diagram.

AGFI

The AGFI (adjusted goodness-of-fit index) takes into account the degrees of freedom 
available for testing the model. It is given by

where

The AGFI is bounded above by 1, which indicates a perfect fit. It is not, however, 
bounded below by 0, as the GFI is.

Note: Use the \agfi text macro to display the value of the adjusted GFI in the output 
path diagram.
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PGFI

The PGFI (parsimony goodness-of-fit index), suggested by Mulaik, et al. (1989), is a 
modification of the GFI that takes into account the degrees of freedom available for 
testing the model

where d is the degrees of freedom for the model being evaluated, and

is the degrees of freedom for the baseline zero model.

Note: Use the \pgfi text macro to display the value of the parsimonious GFI in the 
output path diagram.

Miscellaneous Measures

Miscellaneous fit measures are described here.

HI 90

Amos reports a 90% confidence interval for the population value of several statistics. 
The upper and lower boundaries are given in columns labeled HI 90 and LO 90.

HOELTER

Hoelter’s (1983) critical N is the largest sample size for which one would accept the 
hypothesis that a model is correct. Hoelter does not specify a significance level to be 
used in determining the critical N, although he uses 0.05 in his examples. Amos reports 
a critical N for significance levels of 0.05 and 0.01. 
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Here are the critical N’s displayed by Amos for each of the models in Example 6:

Model A, for instance, would have been accepted at the 0.05 level if the sample 
moments had been exactly as they were found to be in the Wheaton study but with a 
sample size of 164. With a sample size of 165, Model A would have been rejected. 
Hoelter argues that a critical N of 200 or better indicates a satisfactory fit. In an analysis 
of multiple groups, he suggests a threshold of 200 times the number of groups. 
Presumably this threshold is to be used in conjunction with a significance level of 0.05. 
This standard eliminates Model A and the independence model in Example 6. Model B 
is satisfactory according to the Hoelter criterion. I am not myself convinced by 
Hoelter’s arguments in favor of the 200 standard. Unfortunately, the use of critical N 
as a practical aid to model selection requires some such standard. Bollen and Liang 
(1988) report some studies of the critical N statistic.

Note: Use the \hfive text macro to display Hoelter’s critical N in the output path 
diagram for , or the \hone text macro for .

LO 90

Amos reports a 90% confidence interval for the population value of several statistics. 
The upper and lower boundaries are given in columns labeled HI 90 and LO 90.

RMR

The RMR (root mean square residual) is the square root of the average squared amount 
by which the sample variances and covariances differ from their estimates obtained 
under the assumption that your model is correct.

Model HOELTER
0.05

HOELTER
0.01

Model A: No Autocorrelation 164 219
Model B: Most General 1615 2201
Model C: Time-Invariance 1925 2494
Model D: A and C Combined 216 277
Independence model 11 14
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The smaller the RMR is, the better. An RMR of 0 indicates a perfect fit.
The following output from Example 6 shows that, according to the RMR, Model A 

is the best among the models considered except for the saturated model:

Note: Use the \rmr text macro to display the value of the root mean square residual in 
the output path diagram.

Selected List of Fit Measures

If you want to focus on a few fit measures, you might consider the implicit 
recommendation of Browne and Mels (1992), who elect to report only the following 
fit measures:

“CMIN” on p. 585

“P” on p. 585

“FMIN” on p. 588

“F0” on p. 589, with 90% confidence interval

“PCLOSE” on p. 591

“RMSEA” on p. 589, with 90% confidence interval

“ECVI” on p. 593, with 90% confidence interval (See also “AIC” on p. 591)

For the case of maximum likelihood estimation, Browne and Cudeck (1989, 1993) 
suggest substituting MECVI (p. 594) for ECVI.

Model RMR GFI AGFI PGFI

Model A: No Autocorrelation 0.284 0.975 0.913 0.279
Model B: Most General 0.757 0.998 0.990 0.238
Model C: Time-Invariance 0.749 0.997 0.993 0.380
Model D: A and C Combined 0.263 0.975 0.941 0.418
Saturated model 0.000 1.000
Independence model 12.342 0.494 0.292 0.353
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D
Numeric Diagnosis of 
Non-Identifiability

In order to decide whether a parameter is identified or an entire model is identified, 
Amos examines the rank of the matrix of approximate second derivatives and of some 
related matrices. The method used is similar to that of McDonald and Krane (1977). 
There are objections to this approach in principle (Bentler and Weeks, 1980; 
McDonald, 1982). There are also practical problems in determining the rank of a 
matrix in borderline cases. Because of these difficulties, you should judge the 
identifiability of a model on a priori grounds if you can. With complex models, this 
may be impossible, so you will have to rely on the numeric determination of Amos. 
Fortunately, Amos is pretty good at assessing identifiability in practice.
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E
Using Fit Measures to Rank Models

In general, it is hard to pick a fit measure because there are so many from which to 
choose. The choice gets easier when the purpose of the fit measure is to compare 
models to each other rather than to judge the merit of models by an absolute standard. 
For example, it turns out that it does not matter whether you use RMSEA, RFI, or TLI 
when rank ordering a collection of models. Each of those three measures depends on 

 and d only through , and each depends monotonically on . Thus, each 
measure gives the same rank ordering of models. For this reason, the specification 
search procedure reports only RMSEA.

The following fit measures depend on  and d only through , and they depend 
monotonically on . The specification search procedure reports only CFI as 
representative of them all.
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 (not reported by Amos)

The following fit measures depend monotonically on  and not at all on d. The 
specification search procedure reports only  as representative of them all.

Each of the following fit measures is a weighted sum of  and d and can produce a 
distinct rank order of models. The specification search procedure reports each of them 
except for CAIC.
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Using Fit Measures to Rank Models

Each of the following fit measures is capable of providing a unique rank order of 
models. The rank order depends on the choice of baseline model as well. The 
specification search procedure does not report these measures.

The following fit measures are the only ones reported by Amos that are not functions 
of  and d in the case of maximum likelihood estimation. The specification search 
procedure does not report these measures.

IFI Δ2=

PNFI

PCFI

Ĉ

GFI
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F
Baseline Models for Descriptive Fit 
Measures

Seven measures of fit (NFI, RFI, IFI, TLI, CFI, PNFI, and PCFI) require a null or 
baseline bad model against which other models can be compared. The specification 
search procedure offers a choice of four null, or baseline, models:

Null 1: The observed variables are required to be uncorrelated. Their means and 
variances are unconstrained. This is the baseline Independence model in an ordinary 
Amos analysis when you do not perform a specification search.

Null 2: The correlations among the observed variables are required to be equal. The 
means and variances of the observed variables are unconstrained.

Null 3: The observed variables are required to be uncorrelated and to have means of 0. 
Their variances are unconstrained. This is the baseline Independence model used by 
Amos 4.0.1 and earlier for models where means and intercepts are explicit model 
parameters.

Null 4: The correlations among the observed variables are required to be equal. The 
variances of the observed variables are unconstrained. Their means are required to be 0.

Each null model gives rise to a different value for NFI, RFI, IFI, TLI, CFI, PNFI, and 
PCFI. Models Null 3 and Null 4 are fitted during a specification search only when 
means and intercepts are explicitly estimated in the models you specify. The Null 3 
and Null 4 models may be appropriate when evaluating models in which means and 
intercepts are constrained. There is little reason to fit the Null 3 and Null 4 models in 
the common situation where means and intercepts are not constrained but are 
estimated for the sole purpose of allowing maximum likelihood estimation with 
missing data.
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Appendix F

To specify which baseline models you want to be fitted during specification searches:

E From the menus, choose Analyze → Specification Search.

E Click the Options button  on the Specification Search toolbar.

E In the Options dialog box, click the Next search tab.

The four null models and the saturated model are listed in the Benchmark models 
group.
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Append ix

G
Rescaling of AIC, BCC, and BIC

The fit measures, AIC, BCC, and BIC, are defined in Appendix C. Each measure is of 
the form , where k takes on the same value for all models. Small values are 
good, reflecting a combination of good fit to the data (small ) and parsimony 
(small q). The measures are used for comparing models to each other and not for 
judging the merit of a single model.

The specification search procedure in Amos provides three ways of rescaling these 
measures, which were illustrated in Examples 22 and 23. This appendix provides 
formulas for the rescaled fit measures. 

In what follows, let , , and  be the fit values for model i.

Zero-Based Rescaling

Because AIC, BCC, and BIC are used only for comparing models to each other, with 
smaller values being better than larger values, there is no harm in adding a constant, 
as in:

Ĉ kq+
Ĉ

AIC i( ) BCC i( ) BIC i( )

AIC 0
i( ) AIC i( ) min

i
AIC i( )[ ]–=

BCC 0
i( ) BCC i( ) min

i
BCC i( )[ ]–=

BIC 0
i( ) BIC i( ) min

i
BIC i( )[ ]–=
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Appendix G

The rescaled values are either 0 or positive. For example, the best model according to 
AIC has , while inferior models have positive  values that reflect how 
much worse they are than the best model.

E To display , , and  after a specification search, click  on the 
Specification Search toolbar.

E On the Current results tab of the Options dialog box, click Zero-based (min = 0).

Akaike Weights and Bayes Factors (Sum = 1)

E To obtain the following rescaling, select Akaike weights and Bayes factors (sum = 1) on 
the Current results tab of the Options dialog box.

Each of these rescaled measures sums to 1 across models. The rescaling is performed 
only after an exhaustive specification search. If a heuristic search is carried out or if a 
positive value is specified for Retain only the best ___ models, then the summation in 
the denominator cannot be calculated, and rescaling is not performed. The  are 
called Akaike weights by Burnham and Anderson (1998).  has the same 
interpretation as . Within the Bayesian framework and under suitable 
assumptions with equal prior probabilities for the models, the  are approximate 
posterior probabilities (Raftery, 1993, 1995).

AIC0 0= AIC0

AIC0 BCC0 BIC0

AICp
i( ) e AIC i( ) 2⁄–

e AIC m( ) 2⁄–

m
∑
-----------------------------=

BCCp
i( ) e BCC i( ) 2⁄–

e BCC m( ) 2⁄–

m
∑
------------------------------=

BICp
i( ) e BIC i( ) 2⁄–

e BIC m( ) 2⁄–

m
∑
-----------------------------=

AICp
i( )

BCCp
i( )

AICp
i( )

BICp
i( )
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Rescaling of AIC, BCC, and BI C

Akaike Weights and Bayes Factors (Max = 1)

E To obtain the following rescaling, select Akaike weights and Bayes factors (max = 1) on 
the Current results tab of the Options dialog box.

For example, the best model according to AIC has , while inferior models 
have  between 0 and 1. See Burnham and Anderson (1998) for further discussion 
of , and Raftery (1993, 1995) and Madigan and Raftery (1994) for further 
discussion of .

AICL
i( ) e AIC i( ) 2⁄–

max
m

e AIC m( ) 2⁄–[ ]
---------------------------------------=

BCCL
i( ) e BCC i( ) 2⁄–

max
m

e BCC m( ) 2⁄–[ ]
----------------------------------------=

BICL
i( ) e BIC i( ) 2⁄–

max
m

e BIC m( ) 2⁄–[ ]
---------------------------------------=

AICL 1=
AICL

AICL

BICL
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additive constant (intercept), 221
ADF, asymptotically distribution-free, 580
admissibility test in Bayesian estimation, 420
AGFI, adjusted goodness-of-fit index, 600
AIC

Akaike information criterion, 309, 591
Burnham and Anderson’s guidelines for, 326

Akaike weights, 614, 615
interpreting, 328
viewing, 327

alternative to analysis of covariance, 145, 241
Amos Graphics, launching, 9
AmosEngine methods, 57
analysis of covariance, 147

alternative to, 145, 241
comparison of methods, 256

Anderson iris data, 521, 539
assumptions by Amos

about analysis of covariance, 241
about correlations among exogenous variables, 

77
about distribution, 35
about missing data, 270
about parameters in the measurement model, 245
about regression, 221

asymptotic, 30
autocorrelation plot, 402, 505

backwards heuristic specification search, 358
baseline model, 611

comparisons to, 594
specifying, 612

Bayes factors, 614, 615
rescaling of, 331

Bayes’ Theorem, 385

Bayesian estimation, 385
of additional estimands, 428

Bayesian imputation, 462
BCC

Browne-Cudeck criterion, 309, 592
Burnham and Anderson’s guidelines for, 326
comparing models using, 326

best-fit graph
for C, 338
for fit measures, 339
point of diminishing returns, 339

BIC
Bayes information criterion, 592
comparing models using, 347

bootstrap, 295–301
ADF, 314
approach to model comparison, 303–310
compare estimation methods, 311–318
failures, 309
GLS, 314
ML, 314
monitoring progress, 297
number of samples, 297, 307
samples, 303
shortcomings, 296
table of diagnostic information, 299
ULS, 314

boundaries. See category boundaries
burn-in samples, 395

CAIC, consistent AIC, 593
calculate

critical ratios, 110
standardized estimates, 33

category boundaries, 495
censored data, 475
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CFI, comparative fit index, 598
change

default behavior, 243
defaults, 243
fonts, 27
orientation of drawing area, 86

chi-square probability method, 281
chi-square statistic, 53

display in figure caption, 53
classification errors, 536
CMIN

minimum discrepancy function C, 120, 585
table, 368

CMIN/DF, minimum discrepancy function divided 
by degrees of freedom, 587

combining results of multiply imputed data files, 471
common factor analysis model, 139
common factor model, 138
common factors, 139
comparing models

using Bayes factors, 329
using BCC, 326
using BIC, 328, 347

complex model, 584
conditional test, 260
conditions for identifiability, 140
confidence limits, 601, 602
consistent AIC (CAIC), 309
constrain

covariances, 44
means and intercepts, 378
parameters, 14
variances, 42

constraints
add to improve model, 110

conventional linear regression, 67
conventions for specifying group differences, 161
convergence

in Bayesian estimation, 396
in distribution, 396
of posterior summaries, 397

copy
path diagram, 21

text output, 21
correlation estimates as text output, 34
correlations among exogenous variables, 77
covariances

draw, 190
label, 191
structural, 365
unbiased estimates, 242

create
a second group, 191
path diagram, 87

credible interval, 386
credible regions, 406
critical ratio, 30

calculate, 110
cross-group constraints, 232

generating, 379
parameters affected by, 366
setting manually, 369

custom estimands, 437

data and model specification methods, 57
data files, 11
data imputation, 270, 461, 484, 516
data input, 46
data recoding, 477, 492, 512
declarative methods, 57
defaults, changing, 243
degrees of freedom, 32
descriptive fit measures, 611
DF, degrees of freedom, 584
diagnostics

MCMC, 504
direct effect, 122
discrepancy functions, 579
distribution assumptions for Amos models, 35
drag properties option, 189
draw covariances, 190
drawing area

add covariance paths, 90
add unobserved variable, 90



631

Index

change orientation of, 86
viewing measurement weights, 366

duplicate measurement model, 88

ECVI, expected cross-validation index, 593
endogenous variables, 69, 76
EQS (SEM program), 243
equality constraints, 140
equation format for AStructure method, 78
establishing covariances, 27
estimate means and intercepts option

when not selected, 212
when selected, 212

estimating
indirect effects, 425
means, 209
variances and covariances, 23

European Values Study Group, 489
exhaustive specification search, 358
exogenous variables, 38, 69, 76, 78
exploratory analysis, 101
exploratory factor analysis, 344, 349

F0, population discrepancy function, 589
factor analysis, 137

exploratory, 349
model, 229
with structured means, 229

factor loadings, 139, 365
factor means

comparing, 370
removing constraints, 371

factor score weights, 122
Fisher iris data, 521, 539
fit measures, 583, 603, 607
fitting all models, 368

in a single analysis, 188
fixed variables, 35
FMIN, minimum value of discrepancy F, 588

forward heuristic specification search, 358
free parameters, 38

generated models, 367
generating cross-group constraints, 379
GFI, goodness-of-fit index, 599
GLS, generalized least squares, 580
graph

best-fit, 338
scatterplot of fit and complexity, 333
scree plot, 340

GroupName method, 172

heuristic specification search, 349, 358
backwards, 358
forward, 358
limitations of, 361
stepwise, 358, 359

HOELTER, critical N, 601
homogeneity of variances and covariances, 546
hypothesis testing, 52

identifiability, 67, 139, 605
conditions for, 140

identification constraints, 148
IFI, incremental fit index, 597
improper solutions, 410
imputation

Bayesian, 462
data, 461, 484, 516
model-based, 462
multiple, 462
regression, 461
stochastic regression, 461

independence model, 272, 275, 306, 583
indirect effects, 122

estimating, 425
finding a confidence interval for, 431
viewing standardized, 427
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inequality constraints on data, 481, 488
information-theoretic measures of fit, 591
iris data, 521, 539

journals about structural equation modeling, 4
just-identified model, 73

label
output, 51
variances and covariances, 191

label switching, 554, 576
latent structure analysis, 537, 553
latent variable

posterior predictive distribution, 511
linear dependencies, 69
LISREL (SEM program), 243
listwise deletion, 269

MCMC diagnostics, 504
means and intercept

modeling, 209
means and intercepts

constraining, 370, 378
measurement error, 69
measurement model, 83, 304
measurement residuals, 366
measurement weights, 365

viewing in the drawing area, 366
measures of fit, 583
MECVI, modified expected cross-validation index, 

594
methods for retrieving results, 57
minimum discrepancy function C, 120
missing data, 269–293
misuse of modification indices, 110
mixture modeling, 521
ML, maximum likelihood estimation, 579

model
common factor, 138
common factor analysis, 139
complex, 584
draw, 140
drawing arrows in, 13
drawing variables in, 11
factor analysis, 229
generated, 367
identification, 67, 70, 85, 103, 131, 139, 148, 230
improve by adding new constraints, 110
independence, 272, 275, 306, 583
just-identified, 73
measurement, 83, 304
modification, 104
naming variables in, 12
nested, 260
new, 10
nonrecursive, 76, 129, 131
recursive, 76
regression, 9
rejection of, 104
saturated, 73, 272, 275, 306, 583
simple, 584
simultaneous equations, 175
specification, 38
specify, 11
stable, 135
structural, 84
test one against another, 96
unstable, 135
without means and intercepts, 363
zero, 583

model-based imputation, 462
models

individual, view graphics for, 119
multiple in a single analysis, 116
multiple, view statistics for, 119

modification indices, 105, 110, 382
misuse of, 110
request, 149

move objects, 15
multiple imputation, 462
multiple models in a single analysis, 116
multiple-group analysis, 377
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multiple-group factor analysis, 363
multiply imputed data file, combining results, 471
multiply imputed data sets, 469
multivariate analysis of variance, 216

naming
groups, 196
variables, 26

NCP, noncentrality parameter, 588
negative variances, 153
nested models, 260
new group, 56, 77, 172
NFI, normed fit index, 595
NNFI, non-normed fit index, 597
non-diffuse prior distribution, 409
non-identifiability, 605
nonrecursive model, 76, 129, 131
normal distribution, 35
NPAR, number of parameters, 584
null model, 611
numeric custom estimands, 443

obtain
critical rations for parameter differences, 182
squared multiple correlations, 133
standardized estimates, 133, 142

Occam’s window, symmetric, 331
optional output, 16, 33, 48, 121
ordered-categorical data, 489

P, probability, 585
pairwise deletion, 270
parameter constraints, 41
parameter estimation

structure specification, 78
parameters

affected by cross-group constraints, 366
equal, benefits of specifying, 44

specifying equal, 43
parsimony, 584
parsimony index, 598
path diagram, 3

alter the appearance, 15
attach data file, 24, 46
constrain parameters, 14
copy, 21
create, 87
delete an object, 15
display chi-square statistics, 53
draw arrows, 13
duplicate measurement model, 88
format objects, 45
move objects, 15, 45
new, 24
print, 20
redo an action, 16
reshape an object, 15
rotate indicators, 88
specify group name in caption, 176
undo an action, 16

PCFI, parsimonious comparative fit index, 599
PCLOSE, for close fit of the population RMSEA, 

591
PGFI, parsimony goodness-of-fit index, 601
Plot window

display best-fit graphs, 339
scree plot, 340

PNFI, parsimonious normed fit index, 599
point of diminishing returns, 332, 339, 342
population discrepancy

measure of model adequacy, 588
posterior

distribution, 385
mean, 386
standard deviation, 386

posterior predictive distribution, 481, 506, 535, 551, 
572

for a latent variable, 511
PRATIO, parsimony ratio, 585
predictive distribution. See posterior predictive dis-

tribution
predictor variables, 36
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prior distribution, 385, 387, 409
of group proportions, 575

probability, 30

random number seed, 392
random variables, 35
recoding data, 477, 492, 512
recursive model, 76
regression imputation, 461
regression model, 9, 14, 478
regression weights

fix, 70
making optional, 351
unidentified, 73

request modification indices, 149
rescaled measures, 613
reshape an object, 15
RFI, relative fit index, 596
RMR, root mean square residual, 602
RMSEA, root mean square error of approximation, 

589
RNI, relative noncentrality index, 598
rotate indicators, 88

saturated model, 73, 272, 275, 306, 583
scatterplot

adjusting line of constant fit, 335
adjusting line representing C - df, 337
line representing C - df, 336
line representing constant fit, 335
of fit and complexity, 333
other lines representing constant fit, 338

scree plot, 342
for C, 340

seed, random number, 392
Semnet, 5
simple model, 584
simultaneous analysis of several groups, 159
simultaneous equations model, 175

simultaneous factor analysis, 195
SLS, scale-free least squares, 581
space vertically, 190
specification search, 319–348

Akaike weights, 327
CAIC, 608
CFI, 607
comparing models using Bayes factor, 329
comparing models using BCC, 326
comparing models using BIC, 328
confirmatory, 320
exploratory factor analysis, 344, 349
generated models, 324
heuristic, 349, 358
increasing speed of, 323
limiting models retained, 322
number of parameters to use, 332
optional arrows, 345
parameter estimates, 325
performing, 323
point of diminishing returns, 332
program options, 322
required arrows, 321
resetting defaults, 322, 345
RMSEA, 607
viewing fit measures, 323
with few optional arrows, 320

specify
benefits of equal parameters, 44
equal paramaters, 43
group name in figure caption, 176

specifying group differences
conventions, 161

squared multiple correlation, 144
stability index, 135
stability test in Bayesian estimation, 420
stable model, 135
standardized estimates, 33, 132

obtain, 142
view, 143

statistical hypothesis testing, 104
stochastic regression imputation, 461
structural covariances, 365
structural equation modeling, 2
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journals, 4
methods for estimating, 2

structural model, 84
structure specification, 57, 78, 79

parameter estimation, 78
survival time, 476
symettric Occam’s window, 331

test for uncorreletated variables, 60
testing hypotheses about means, 209
text file with results, 56
text macros, 52, 584–603
text output

copy, 21
thinning, 414
thresholds. See category boundaries
time-series plot, 401
TLI, Tucker-Lewis index, 597
total effect, 123
trace plot, 401, 504, 554
training data, 521

ULS, unweighted least squares, 581
unbiased estimates of variance and covariances, 242
uncorrelated variables, 60
unidentified regression weights, 73
unique factor, 139
unique variables, 78
unobserved variables, 81
unstable model, 135
using BCC to compare models, 354

variables
endogenous, 69, 76
entering names, 90
exogenous, 69, 76, 78
unique, 78
unobserved, 81

variances
label, 191
unbiased estimates, 242

view
generated models, 367
graphics output, 19, 28
parameter subsets, 366
standardized estimates, 143
standardized indirect effects, 427
text output, 18, 29

zero model, 583
zero-based rescaling, 613




